Search found 5 matches

by peteclyde
Thu Dec 29, 2016 9:32 am
Forum: Installation Problems
Topic: Keep VRS running after closing telnet session
Replies: 10
Views: 3144

Re: Keep VRS running after closing telnet session

Program stops when I start it with & pi@raspberrypi:~ $ mono /home/pi/vrs/VirtualRadar.exe -nogui & [1] 1238 pi@raspberrypi:~ $ Parsing command-line parameters Initialising the log Initialising user manager Loading the configuration Starting picture folder cache Opening the BaseStation database Load...
by peteclyde
Thu Dec 29, 2016 4:52 am
Forum: Installation Problems
Topic: Keep VRS running after closing telnet session
Replies: 10
Views: 3144

Re: Keep VRS running after closing telnet session

Hi

It just started the program as if the & wasn't there.... like the & had no effect.

PM
by peteclyde
Wed Dec 28, 2016 5:33 am
Forum: Installation Problems
Topic: Keep VRS running after closing telnet session
Replies: 10
Views: 3144

Re: Keep VRS running after closing telnet session

Hey Argz,

The first option

Code: Select all

mono /home/pi/vrs/VirtualRadar.exe -nogui &
didn't work, but the second one works fine.

Code: Select all

#!/bin/sh
mono /home/pi/vrs/VirtualRadar.exe -nogui
chmod +x  /home/pi/vrs.sh
crontab -e
@reboot  /home/pi/vrs.sh
Thanks heaps,

Pete
by peteclyde
Mon Dec 26, 2016 10:36 pm
Forum: Installation Problems
Topic: Keep VRS running after closing telnet session
Replies: 10
Views: 3144

Re: Keep VRS running after closing telnet session

OK, got it sorted, not sure if it's the best way but it works. Installed tmux on my Raspberry pi pi@raspberrypi:~ $ sudo apt-get install tmux Started tmux pi@raspberrypi:~ $ tmux Inside the tmux terminal I started VRS mono /home/pi/vrs/VirtualRadar.exe -nogui Then to exit tmux, but leave VRS running...
by peteclyde
Fri Dec 23, 2016 2:55 am
Forum: Installation Problems
Topic: Keep VRS running after closing telnet session
Replies: 10
Views: 3144

Keep VRS running after closing telnet session

Hey all, I've got VRS running on my Pi3 - to get it started I telnet / ssh into the Pi, and run mono VirtualRadar.exe -nogui I've got no troubles access the web interface, as well as the admin section. However, when I either hit the Q button in the ssh session, or close Putty, the program stops. I'v...