Flag and Silhouette Troubles with Safari on Catalina

Are you having trouble getting Virtual Radar Server installed and running? If so then this is the place to ask about it.
Post Reply
roadfun
Posts: 9
Joined: Mon Feb 06, 2017 6:58 pm

Flag and Silhouette Troubles with Safari on Catalina

Post by roadfun » Tue Jan 07, 2020 4:22 pm

I got a new computer last year replacing the one I used to use for VRS and I am running macOS Catalina on the new one. I just had time to revive VRS on my new Mac. It all went very smoothly except for the fact almost no silhouette/aircraft icons show up on the map. That is unless I turn on "Show Altitude Stalk" in which case the aircraft icons are drawn. Toggling using the "old aircraft markers" doesn't make a difference nor did fiddling with other settings. There is a less severe problem with flags and silhouettes in the aircraft list - most silhouettes and flags are shown in the list but some are missing.

I fiddled with versions of mono and so on without finding a fix (from 6.4.0 on back to 5.0). I then viewed VRS using Firefox on the Mac and voila everything is displayed as expected. Interestingly, at least to me, if I view VRS using Safari on my iPad everything is shown correctly.

Has anyone seen or have ideas for how to fix the display on Safari Catalina? It's not the end of the world of course since I can run Firefox but I'd rather not have to do that.

Note: I'm running VRS 2.4.2.2943. I never saw this issue prior to the new Mac/Catalina.

Cheers

Post Reply