Install or MLAT problem

Are you having trouble getting Virtual Radar Server installed and running? If so then this is the place to ask about it.
orion_jb2001
Posts: 22
Joined: Sat Oct 29, 2016 6:12 am

Install or MLAT problem

Post by orion_jb2001 » Sun Oct 30, 2016 1:22 am

Hi all,

Just getting into VRS. My set up: Pi3, running Joe's ADS B receiver project ver 2.4. Feeding Flightaware and also ADS B exchange. VRS installed on windows PC. Drawing data from my local net of the Pi3. Established connection via 30005, no probs and A/C showing. On my dump 1090 map, being viewed from the local net of ADS B receiver project, on my PC, ADS B receiver maps showing, including MLAT A/C. Problem with the VRS, connection 30104, which should be receiving MLAT data from FA and also ADS B exchange, is not receiving any data. I have set up in VRS, a specific receiver for 30104, named MLAT. The test connection feature indicates connection can be established. Not sure why I am not getting any data from 30104??

Jeff

DeWoert
Posts: 41
Joined: Mon Feb 29, 2016 9:36 pm

Re: Install or MLAT problem

Post by DeWoert » Sun Oct 30, 2016 9:20 am

MLAT data should be availble on port 30105 from your PI as an AVR or Beast Raw Feed for VRS.

orion_jb2001
Posts: 22
Joined: Sat Oct 29, 2016 6:12 am

Re: Install or MLAT problem

Post by orion_jb2001 » Sun Oct 30, 2016 9:46 am

Ah that would be a no, didn't work.

DeWoert
Posts: 41
Joined: Mon Feb 29, 2016 9:36 pm

Re: Install or MLAT problem

Post by DeWoert » Sun Oct 30, 2016 10:02 am

Are you using the dump1090-FA of dump1090-mutability version of Joe's ADS B receiver project ver 2.4 ?

Current PiAware (v3.1.0) should provide MLAT at port 30105:
The default settings set up three items:
beast,connect,localhost:30104 - this feeds multilateration results back to the local dump1090 for display on the map
beast,listen,30105 - this provides a Beast binary format feed of multilateration results that can be used by external systems, e.g., VRS
ext_basestation,listen,30106 - like 30105, but in a different format

Code: Select all

ps ax | grep fa-mlat-
  828 ?        S      7:10 /usr/lib/piaware/helpers/fa-mlat-client --input-connect localhost:30005 --input-type dump1090 --results beast,connect,localhost:30104 --results beast,listen,30105 --results ext_basestation,listen,30106 --udp-transport
Also check your piaware.log:

Code: Select all

tail -f /var/log/piaware.log

orion_jb2001
Posts: 22
Joined: Sat Oct 29, 2016 6:12 am

Re: Install or MLAT problem

Post by orion_jb2001 » Sun Oct 30, 2016 10:12 am

Using dump1090-mutability of Joe's 2.4.

orion_jb2001
Posts: 22
Joined: Sat Oct 29, 2016 6:12 am

Re: Install or MLAT problem

Post by orion_jb2001 » Sun Oct 30, 2016 10:17 am

What am I looking for in the log???? And does that code change settings for MLAT to work with VRS??

Jeff

orion_jb2001
Posts: 22
Joined: Sat Oct 29, 2016 6:12 am

Re: Install or MLAT problem

Post by orion_jb2001 » Sun Oct 30, 2016 10:21 am

pi@raspberrypi:~ $ tail -f /var/log/piaware.log
Oct 30 20:55:50 raspberrypi piaware[645]: 1644292 msgs recv'd from dump1090-muta (367 in last 5m); 1643160 msgs sent to FlightAware
Oct 30 21:00:50 raspberrypi piaware[645]: 1644742 msgs recv'd from dump1090-muta (450 in last 5m); 1643610 msgs sent to FlightAware
Oct 30 21:03:02 raspberrypi piaware[645]: mlat-client(26480): Receiver status: connected
Oct 30 21:03:02 raspberrypi piaware[645]: mlat-client(26480): Server status: synchronized with 32 nearby receivers
Oct 30 21:03:02 raspberrypi piaware[645]: mlat-client(26480): Receiver: 175.6 m sg/s received 83.3 msg/s processed (47%)
Oct 30 21:03:02 raspberrypi piaware[645]: mlat-client(26480): Server: 0.0 k B/s from server 0.0kB/s TCP to server 0.8kB/s UDP to server
Oct 30 21:03:02 raspberrypi piaware[645]: mlat-client(26480): Results: 9.3 positions/minute
Oct 30 21:03:02 raspberrypi piaware[645]: mlat-client(26480): Aircraft: 1 of 1 M ode S, 10 of 22 ADS-B used
Oct 30 21:05:50 raspberrypi piaware[645]: 1645094 msgs recv'd from dump1090-muta (352 in last 5m); 1643962 msgs sent to FlightAware
Oct 30 21:10:50 raspberrypi piaware[645]: 1645479 msgs recv'd from dump1090-muta (385 in last 5m); 1644347 msgs sent to FlightAware
Oct 30 21:15:50 raspberrypi piaware[645]: 1645806 msgs recv'd from dump1090-muta (327 in last 5m); 1644674 msgs sent to FlightAware
Oct 30 21:18:03 raspberrypi piaware[645]: mlat-client(26480): Receiver status: connected
Oct 30 21:18:03 raspberrypi piaware[645]: mlat-client(26480): Server status: synchronized with 33 nearby receivers
Oct 30 21:18:03 raspberrypi piaware[645]: mlat-client(26480): Receiver: 182.2 msg/s received 89.1 msg/s processed (49%)
Oct 30 21:18:03 raspberrypi piaware[645]: mlat-client(26480): Server: 0.0 kB/s from server 0.0kB/s TCP to server 0.8kB/s UDP to server
Oct 30 21:18:03 raspberrypi piaware[645]: mlat-client(26480): Results: 1.8 positions/minute
Oct 30 21:18:03 raspberrypi piaware[645]: mlat-client(26480): Aircraft: 1 of 2 Mode S, 11 of 22 ADS-B used

DeWoert
Posts: 41
Joined: Mon Feb 29, 2016 9:36 pm

Re: Install or MLAT problem

Post by DeWoert » Sun Oct 30, 2016 10:23 am

And what does the log provide ?

Code: Select all

cat /var/log/piaware.log
At startup the log should show something like:

Code: Select all

Oct 30 11:21:07 RPi-05 piaware[515]: mlat-client(836): fa-mlat-client 0.2.6 starting up
Oct 30 11:21:07 RPi-05 piaware[515]: mlat-client(836): Using UDP transport to 70.42.6.224 port 6046
Oct 30 11:21:07 RPi-05 piaware[515]: mlat-client(836): Listening for Beast-format results connection on port 30105
Oct 30 11:21:07 RPi-05 piaware[515]: mlat-client(836): Listening for Extended Basestation-format results connection on port 30106
Oct 30 11:21:07 RPi-05 piaware[515]: mlat-client(836): Input connected to localhost:30005
Oct 30 11:21:07 RPi-05 piaware[515]: mlat-client(836): Input format changed to BEAST, 12MHz clock
Oct 30 11:21:07 RPi-05 piaware[515]: mlat-client(836): Beast-format results connection with 127.0.0.1:30104: connection established
Oct 30 11:21:11 RPi-05 piaware[515]: mlat-client(836): Accepted Beast-format results connection from ::ffff:192.168.2.123:62867
Oct 30 11:21:14 RPi-05 piaware[515]: piaware has successfully sent several msgs to FlightAware!

orion_jb2001
Posts: 22
Joined: Sat Oct 29, 2016 6:12 am

Re: Install or MLAT problem

Post by orion_jb2001 » Sun Oct 30, 2016 11:15 am

ps ax | grep fa-mlat-
828 ? S 7:10 /usr/lib/piaware/helpers/fa-mlat-client --input-connect localhost:30005 --input-type dump1090 --results beast,connect,localhost:30104 --results beast,listen,30105 --results ext_basestation,listen,30106 --udp-transport
So do I need to execute this to change that MLAT output to 3105??

DeWoert
Posts: 41
Joined: Mon Feb 29, 2016 9:36 pm

Re: Install or MLAT problem

Post by DeWoert » Sun Oct 30, 2016 11:23 am

orion_jb2001 wrote:
ps ax | grep fa-mlat-
828 ? S 7:10 /usr/lib/piaware/helpers/fa-mlat-client --input-connect localhost:30005 --input-type dump1090 --results beast,connect,localhost:30104 --results beast,listen,30105 --results ext_basestation,listen,30106 --udp-transport
So do I need to execute this to change that MLAT output to 3105??
No..
The command (ps ax | grep fa-mlat-) is just to show the running service with its commands.
So it's only to check IF and with what parameters the FA-MLAT-client is running on your PI

Post Reply