error by start up MONO Raspberry PI 3

Are you having trouble getting Virtual Radar Server installed and running? If so then this is the place to ask about it.
Post Reply
lesveldt
Posts: 22
Joined: Wed May 18, 2016 12:40 pm

error by start up MONO Raspberry PI 3

Post by lesveldt » Tue Feb 28, 2017 9:51 am

Code: Select all

pi@raspberrypi:~ $ mono /home/pi/Desktop/VirtualRadar/VirtualRadar.exe -nogui -createAdmin:admin -password:password
Parsing command-line parameters
Initialising the log
Initialising user manager
Loading the configuration
Starting picture folder cache
Opening the BaseStation database
Loading standing data
Initialising air pressure manager
Connecting to data feed
Starting web server
Starting rebroadcast servers
Initialising UPnP manager
Initialising online lookup manager
Starting plugins
Missing method System.Array::Empty<[1]>() in assembly /usr/lib/mono/4.5/mscorlib.dll, referenced in assembly /home/pi/Desktop/VirtualRadar/Plugins/DatabaseEditor/VirtualRadar.Plugin.DatabaseEditor.dll
A Plugin Threw An Exception During Startup
Plugin Database Editor threw an exception (Method not found: 'System.Array.Empty'.) when it was started - it remains loaded but may not behave correctly. Full details are in the log.
Local address: http://127.0.0.1:8080/VirtualRadar
Network address: http://192.168.2.38:8080/VirtualRadar
Press Q to quit
LOG:

[2017-02-28 09:47:49.543 UTC] [t1] Program started, version 2.4.0.26790, build date 18/02/2017 14:53:00 UTC
[2017-02-28 09:47:49.548 UTC] [t1] Working folder /home/pi/.local/share/VirtualRadar
[2017-02-28 09:47:50.132 UTC] [t1] Exception caught during load of standing data: Mono.Data.Sqlite.SqliteException: Unable to open the database file
at Mono.Data.Sqlite.SQLite3.Open (System.String strFilename, SQLiteOpenFlagsEnum flags, Int32 maxPoolSize, Boolean usePool) [0x00000] in <filename unknown>:0
at Mono.Data.Sqlite.SqliteConnection.Open () [0x00000] in <filename unknown>:0
[2017-02-28 09:47:51.055 UTC] [t1] Caught exception when starting Database Editor: System.MissingMethodException: Method not found: 'System.Array.Empty'.
at VirtualRadar.Plugin.DatabaseEditor.Options..ctor () [0x00000] in <filename unknown>:0
at VirtualRadar.Plugin.DatabaseEditor.OptionsStorage.Load (VirtualRadar.Plugin.DatabaseEditor.Plugin plugin) [0x00000] in <filename unknown>:0
at VirtualRadar.Plugin.DatabaseEditor.Plugin.Startup (VirtualRadar.Interface.PluginStartupParameters parameters) [0x00000] in <filename unknown>:0
at VirtualRadar.Library.Presenter.SplashPresenter.StartPlugins (IWebSite webSite) [0x00000] in <filename unknown>:0
Last edited by lesveldt on Wed Mar 15, 2017 1:01 pm, edited 1 time in total.

lesveldt
Posts: 22
Joined: Wed May 18, 2016 12:40 pm

Re: error by start up MONO Raspberry PI 3

Post by lesveldt » Tue Feb 28, 2017 10:02 am

and after trying to connect via internet i got this in my terminal:

Code: Select all

Missing method get_Name in assembly /home/pi/Desktop/VirtualRadar/VirtualRadar.WebServer.dll, type System.Security.Claims.ClaimsIdentity
Unhandled Exception Caught
System.TypeLoadException: Could not load type 'System.Security.Claims.ClaimsIdentity' from assembly 'VirtualRadar.WebServer'.
  at VirtualRadar.WebServer.WebServer+DefaultProvider.EndGetContext (IAsyncResult asyncResult) [0x00000] in <filename unknown>:0 
  at VirtualRadar.WebServer.WebServer.GetContextHandler (IAsyncResult asyncResult) [0x00000] in <filename unknown>:0 

agw
Posts: 2247
Joined: Fri Feb 17, 2012 3:20 am

Re: error by start up MONO Raspberry PI 3

Post by agw » Wed Mar 15, 2017 11:42 pm

The next version of VRS is targeting version 4.6.1 of .NET, which isn't supported in versions of Mono earlier than 4.2 (from memory) - you will need to upgrade the version of Mono that you've got installed. I think that might be tricky if you're using Raspian, from what I understand that's still stuck on an older version of Mono. You either need to stick with the current release version of VRS or build the latest Mono from source.

Post Reply