Problem after Create User - Raspberry Pi 3 B

Are you having trouble getting Virtual Radar Server installed and running? If so then this is the place to ask about it.
Post Reply
Posts: 1
Joined: Sat Nov 04, 2017 7:43 pm

Problem after Create User - Raspberry Pi 3 B

Post by bugsbunny » Sat Nov 04, 2017 7:52 pm

i cant create User over the intern Raspberry Terminal.
The VRS Show a long list and close.

My Settings:

- Raspberry PI 3 Model B
- latest Version of VRS and WebAdmin
(and the Feb Version produce the sam)

And a new failure after open the VRS Webpage in Browser.
Missing method get_Name in assembly /home/pi/VRS/VirtualRadar.WebServer.dll, type System.Security.Claims.ClaimsIdentity
Unhandled Exception Caught
System.TypeLoadException: Could not load type 'System.Security.Claims.ClaimsIdentity' from assembly 'VirtualRadar.WebServer'.
at VirtualRadar.WebServer.WebServer+DefaultProvider.EndGetContext (IAsyncResult asyncResult) [0x00000] in <filename unknown>:0
at VirtualRadar.WebServer.WebServer.GetContextHandler (IAsyncResult asyncResult) [0x00000] in <filename unknown>:0
Has anybody an idea?


Posts: 19
Joined: Mon Apr 30, 2012 10:40 pm

Re: Problem after Create User - Raspberry Pi 3 B

Post by ianhind » Sat Dec 30, 2017 6:51 pm

You might want to have a look here about installing more recent versions of Mono.

I'm installing on Debian on a PC and had the same error but folowing the instructions to install a leter version of Mono worked.

@Andy - currently the above referenced thread from a year ago refers to "SVG graphics and .NET 4.6".
It is possibly more relevant for the WebAdmin addin. I only found the solution from a Google search, not by looking at the titles of the threads. Perhaps add a reference in the installation instructions?


Post Reply