Page 1 of 1

Problem after Create User - Raspberry Pi 3 B

Posted: Sat Nov 04, 2017 7:52 pm
by bugsbunny
Hello,
i cant create User over the intern Raspberry Terminal.
The VRS Show a long list and close.

My Settings:

- Raspberry PI 3 Model B
- latest Version of VRS and WebAdmin
(and the Feb Version produce the sam)

And a new failure after open the VRS Webpage in Browser.
Missing method get_Name in assembly /home/pi/VRS/VirtualRadar.WebServer.dll, type System.Security.Claims.ClaimsIdentity
Unhandled Exception Caught
System.TypeLoadException: Could not load type 'System.Security.Claims.ClaimsIdentity' from assembly 'VirtualRadar.WebServer'.
at VirtualRadar.WebServer.WebServer+DefaultProvider.EndGetContext (IAsyncResult asyncResult) [0x00000] in <filename unknown>:0
at VirtualRadar.WebServer.WebServer.GetContextHandler (IAsyncResult asyncResult) [0x00000] in <filename unknown>:0
Has anybody an idea?


Philipp

Re: Problem after Create User - Raspberry Pi 3 B

Posted: Sat Dec 30, 2017 6:51 pm
by ianhind
You might want to have a look here about installing more recent versions of Mono.
viewtopic.php?f=11&t=1225

I'm installing on Debian on a PC and had the same error but folowing the instructions to install a leter version of Mono worked.

@Andy - currently the above referenced thread from a year ago refers to "SVG graphics and .NET 4.6".
It is possibly more relevant for the WebAdmin addin. I only found the solution from a Google search, not by looking at the titles of the threads. Perhaps add a reference in the installation instructions?

Ian