Page 1 of 1

External access to VRS stopped working

Posted: Sat Dec 08, 2018 8:19 am
by larsras
Have had VRS running for years, and external access has never been an issue, but now it suddenly stopped working. Connection attempts just times out.
Latest official VRS version used.
The WWW server can be accessed on the source PC, and on other PC's on the LAN.
LAN/WAN HW Firewall is still configured correctly, and not touched for month. Other services running on the same PC and configured the same way in the FW can be accessed successfully.
I can see in the FW log that access to VRS is passed through.

Any ideas what has gone wrong here?

Thanks!

Re: External access to VRS stopped working

Posted: Sun Dec 09, 2018 9:52 pm
by Skibox
Could your ISP have started using CGN so you are no longer getting a real IP from them?

Check WAN IP in router and see if it matches what you see on whatsmyip.com

/M

Re: External access to VRS stopped working

Posted: Tue Dec 11, 2018 4:22 pm
by larsras
Thanks. Had to read a bit on CGN.
I'm paying for a static ip, but that is kind of internal on my ISP's network. For it all to work i also have dyndns.org.
So i can successfully access other similar services / ports on the PC, but just not VRS. All is configured the same way, just with different port numbers, and i can in the FW log see that requests to VRS get's inside the FW.

Re: External access to VRS stopped working

Posted: Sat Dec 29, 2018 3:08 pm
by agw
If you are seeing incoming requests in the firewall log and the client is not getting replies then you have a firewall somewhere blocking the replies. Bear in mind that the replies will be to a random port number chosen by the client, your firewall needs to know that it has to allow the replies out as well as pass the requests on to VRS. The firewall on the machine that's running VRS will also need to let VRS talk to machines on the public network as well as your private or domain network.