Show internet address won't work

Are you having trouble getting Virtual Radar Server installed and running? If so then this is the place to ask about it.
Hoggorm
Posts: 17
Joined: Mon Feb 03, 2014 12:15 pm

Show internet address won't work

Post by Hoggorm » Tue Feb 04, 2014 7:16 pm

Both local and network addresses work fine, but when trying the internet address, I get a "404 Not Found, File not found" error.

I'm not at all very good with computers and port forwarding etc, but any idea what might cause the problem?

Thanks

jonfear
Posts: 365
Joined: Sat Feb 09, 2013 12:15 pm
Location: Wick St Lawrence
Contact:

Re: Show internet address won't work

Post by jonfear » Tue Feb 04, 2014 8:54 pm

I assume that you are trying to see the your VRS server from the outside "internet" world. If this is the case then certainly you will have to set up port forwarding within your modem / router. Unfortunately there are many ways to set this up depending on the specific make of router.

I would google your make and model number and see if anyone has a how-to written that may help. You should not have to do anything special unless you are already running a web server within your network, which I doubt from what you have written.

If you post the details (Make and Model number), we will see if we can help!

Good luck

Jon
http://www.360radar.co.uk, the new name for MLAT Radar in the UK and Western Europe.

Former PP feeder Bm. No longer feeding. I do not have time to sort out imaginary problems with NTP
when it has been working fine for 2+ Years.

Hoggorm
Posts: 17
Joined: Mon Feb 03, 2014 12:15 pm

Re: Show internet address won't work

Post by Hoggorm » Tue Feb 04, 2014 9:19 pm

Yes, I would like some friends of mine to be able to see the traffic my receiver is seeing. I've both given the address VRS provides to my friends and tried to access it via 3G on my mobile phone myself, without luck.

I have the Cisco Linksys E2500 router and tried to set it up with the information as shown here:

https://www.dropbox.com/s/wvz1enp95n7d9 ... .13.15.png

I have no idea if any of the input I've made is correct, neither 80 both or 138. The Enable box was checked, but it did not work, so I unchecked it before taking the screenshot.

agw
Posts: 2247
Joined: Fri Feb 17, 2012 3:20 am

Re: Show internet address won't work

Post by agw » Tue Feb 04, 2014 9:58 pm

If you get a 404 error then that means a server somewhere replied to your browser's request, so chances are you're already most of the way there to getting it working.

If you didn't change the port number when you installed VRS then you're right with the port 80 for the internal port number. The external port number can be anything (almost), but 80 is the default port for web traffic so unless your ISP blocks port 80 traffic that's also going to be OK.

To check whether the 138 address is correct you can run VRS and in the dropdown on the main screen that says "Show local address" change it to "Show network address". The link over to the right of the screen should change, ideally to "http://192.168.1.138/VirtualRadar" - use the number that VRS is showing if it's different.

When you access the site from the Internet you need to remember the /VirtualRadar on the end of the address, otherwise it'll report an error.

Some ISPs will not allow port 80 traffic through to home consumers, in which case you will need to change the external port so something that isn't usually associated with web traffic. It can be any number between 1024 and 65535 - e.g. 7080. To get VRS to show the correct address if the external port is 7080 go into Tools | Options | Web Server and enter 7080 for "Internet port number". You don't have to do this, it doesn't make any difference to VRS (unless you're using UPnP) - it just includes it in the "Show Internet address" display.

If you're still getting a 404 error then feel free to PM or email me the address and I'll take a look and see what I get from over here :)

jonfear
Posts: 365
Joined: Sat Feb 09, 2013 12:15 pm
Location: Wick St Lawrence
Contact:

Re: Show internet address won't work

Post by jonfear » Wed Feb 05, 2014 4:00 pm

I notice that the forwarding for the 138 address appears to be correct however it is not enabled. The check box has no tick in it. Try enabling the port forward. I am at my PC for a few hours now so feel free to PM me with your url and I will check if Andrew is not available.

Jon
http://www.360radar.co.uk, the new name for MLAT Radar in the UK and Western Europe.

Former PP feeder Bm. No longer feeding. I do not have time to sort out imaginary problems with NTP
when it has been working fine for 2+ Years.

Hoggorm
Posts: 17
Joined: Mon Feb 03, 2014 12:15 pm

Re: Show internet address won't work

Post by Hoggorm » Wed Feb 05, 2014 4:22 pm

It was enabled when I tried, I just ticked it off before I took the screenshot. 138 however was wrong, so I changed it to the correct IP.

Try this link, it should be working now :)

http://82.116.89.14:8080/VirtualRadar/desktop.html

While we're discussing the internett server - I've changed a lot in the settings. Is it possible to default these settings to all who view the page? In the VRS settings I can only find options for zoom, location and map type.

jonfear
Posts: 365
Joined: Sat Feb 09, 2013 12:15 pm
Location: Wick St Lawrence
Contact:

Re: Show internet address won't work

Post by jonfear » Wed Feb 05, 2014 4:40 pm

Working well.

Andrew should be able to help with the settings. He is very much the expert there!

Jon
http://www.360radar.co.uk, the new name for MLAT Radar in the UK and Western Europe.

Former PP feeder Bm. No longer feeding. I do not have time to sort out imaginary problems with NTP
when it has been working fine for 2+ Years.

agw
Posts: 2247
Joined: Fri Feb 17, 2012 3:20 am

Re: Show internet address won't work

Post by agw » Thu Feb 06, 2014 12:32 am

If you install the Custom Content Plugin from the downloads then you can use that to set the defaults that the site uses - there's an overview of the process here:

http://www.virtualradarserver.co.uk/Doc ... tings.aspx

The custom content plugin is brand-new with version 2 of VRS and some of the settings which I had intended to be overridable aren't, or at least they're not easily overridden. But most of the usual things that people tweak on the site are fairly straight-forward to do, and the trickier ones will be easier to override in future versions of VRS. If you run into any problems just let me know.

jmd64
Posts: 4
Joined: Sun Feb 09, 2014 4:24 am

Re: Show internet address won't work

Post by jmd64 » Sun Feb 09, 2014 4:27 am

I am also having this problem.

I have added port 65500 in my router, and changed the settings to that port.

However, still no success

Hopefully someone can help

agw
Posts: 2247
Joined: Fri Feb 17, 2012 3:20 am

Re: Show internet address won't work

Post by agw » Sun Feb 09, 2014 8:57 pm

The port that the router is listening to isn't, or needn't be, the same as the port that VRS is listening to. In the port forwarding settings on the router it will ask for four things (usually):

1. The external port number. This is the port that Internet clients will have to connect to to reach VRS.
2. The internal address. This needs to be the address of the machine that's running VRS on the LAN. This will usually start with either 10 or 192.168, depending on how you've got things set up.
3. The internal port number. This needs to be the port that VRS is listening to. It doesn't have to be the same as the external port number. If you install VRS with the default settings then it'll be 80 for Windows installations and 8080 for Linux installations.
4. The protocol to forward. This should be "TCP", although "Both" will also work.

The router will then route all traffic to your public Internet address at the external port to the internal machine and the internal port. Some routers won't do this redirection for traffic that originates on the network, so if it looks like it's not working and you're not sure whether your router supports this kind of routing then you should test it with a machine on a different network, such as a phone that's been disconnected from the LAN.

Port numbers have to be in the range of 1 to 65535. Port 80 is the default for web traffic, so if you can use it then that's best - it means you don't have to specify the port number in the address. If you can't use 80 (some ISPs will block port 80 traffic to consumer connections) then try to keep the port number above 1024 - those below 1024 are reserved for different kinds of traffic. 8080 or 9090 are usually pretty good bets. In principle you should be alright with 65000 but your life's probably going to be easier if you stick with ports below 10000 - many NAT implementations use high port numbers when they translate ports for outgoing connections, if 65000 is in the range that the NAT stuff will use then you're relying on the router being clever enough to realise that it's been port forwarded and not then try to use it for a NAT connection.

If your router supports UPnP then things get a lot easier, you just enable it in the settings and tell VRS to go onto the Internet.

Post Reply