Missing silhoutes and flags.

Are you having trouble getting Virtual Radar Server installed and running? If so then this is the place to ask about it.
miranzagragja
Posts: 1
Joined: Sat Jun 27, 2015 7:11 pm

Missing silhoutes and flags.

Post by miranzagragja » Sat Jun 27, 2015 7:16 pm

Hi,
There's no silhoeute or flag when I open virtual radar, there's just detail about the planes (altitude etc). The SBS resources webpage doesnt work. Anyone help?

agw
Posts: 2249
Joined: Fri Feb 17, 2012 3:20 am

Re: Missing silhoutes and flags.

Post by agw » Sun Jun 28, 2015 9:59 pm

At the moment you can download silhouettes and operator flags from Kinetic's site:

http://www.kinetic.co.uk/resourcesdownloads.php

Unzip them into separate folders and then tell VRS where the folders are in Tools | Options | Data Sources.

gismoat
Posts: 2
Joined: Tue Jul 07, 2015 12:55 pm

Re: Missing silhoutes and flags.

Post by gismoat » Tue Jul 07, 2015 12:59 pm

Hello,
the silhoutes are from 2008-2011.
How can i get newer silhouets?
Or is it possible to make my personal silhouets?
I missing a lot of types.

E195
E175
CL35
CL64
C55B
F2EX
G550
GL6T
F5EX
G450

agw
Posts: 2249
Joined: Fri Feb 17, 2012 3:20 am

Re: Missing silhoutes and flags.

Post by agw » Sun Jul 12, 2015 11:19 pm

I didn't draw the silhouettes, I think pretty much all of the silhouettes that I've seen used were drawn by Ian Kirby. Sites like Kinetic and SBS Resources package his silhouettes up and they might be a bit out of date. I think this is his site, you can look on there to see if he's got more up-to-date versions of the aircraft you're after:

http://www.sbsbst.co.uk/iank/

If you want to draw your own silhouettes then yes, you can do that. They need to be 85 x 20 pixels and saved as BMP files in the silhouettes folder. The filename must be the ICAO type for the aircraft, e.g. CL35.bmp.

gismoat
Posts: 2
Joined: Tue Jul 07, 2015 12:55 pm

Re: Missing silhoutes and flags.

Post by gismoat » Mon Jul 13, 2015 1:28 pm

Hi agw,
thanks for your help.
On Ian Kirby webpage i can't find the silhouettes where i need.
So i would like create with your instruction the missing silhouettes.

cheers
Werner

Extranet
Posts: 18
Joined: Tue Jul 01, 2014 5:45 pm
Location: Germany
Contact:

Re: Missing silhoutes and flags.

Post by Extranet » Tue Jul 14, 2015 3:55 pm

Hi,

http://www.antonakis.co.uk/sbsflags/ - Is good for finding Flags & Silhouettes , I use it all the time :)

https://groups.yahoo.com/neo/groups/sbsflags/info - Closed group but you can search & download the files

Thanks

Nigel
VRS World is a Private ADSB Network with its own MLAT Server.
If your interested in joining us then please visit our Facebook Group
for more details or email support(at)vrs-world.com

squawk7000
Posts: 5
Joined: Wed Nov 04, 2015 8:01 pm

Re: Missing silhoutes and flags.

Post by squawk7000 » Thu Nov 05, 2015 12:31 pm

Hello everyone,

First post – have just recently discovered this software, brilliant!
Anyway, I’ve got the silhouettes working but can’t get the flags to work.

What am I doing wrong?

Regards squawk7000

agw
Posts: 2249
Joined: Fri Feb 17, 2012 3:20 am

Re: Missing silhoutes and flags.

Post by agw » Thu Nov 05, 2015 10:08 pm

There are a few possibilities - the first is that you have the operator flags in the wrong folder, or the files in there aren't operator flags; the second is that your BaseStation.sqb doesn't have the OperatorFlagCode field filled in.

You can see what you're getting for the operator flag code by showing it on the site. Go to Menu | Options | Aircraft and check that the list under Aircraft Details has an entry for Operator Code. If it does not (it doesn't by default) then click the padlock, select Operator Code in the drop-down list and click Add.

If all of the aircraft have no operator code then that's the problem :) The next version of VRS will support online lookup of aircraft details, and those details include the operator code - that should be in preview within the next couple of weeks so hang tight and wait for that.

Otherwise, if you are seeing operator codes then check that they're valid ICAO operator codes. They should be three letters with no digits, e.g. BAW for British Airways, EZY for easyJet, UAL for United Airlines etc.

If that all looks OK then go into Windows File Explorer and navigate to the directory you've nominated for the Flags Folder in Tools | Options | Data Sources. The files in there should have names that match the ICAO operator codes and they should be BMP files, so in the example from the last paragraph you would need to have files in there called BAW.BMP, EZY.BMP and UAL.BMP to see flags for those three operators.

If that all looks alright then you might have nominated the wrong folder in VRS at some point and your browser has cached the blank image that VRS sends back when it can't find the operator flag in the folder you've specified. If you just wait an hour or so that problem should clear itself, the cache time on those images is an hour (from memory), but you can short circuit that by telling the browser to remove all files and images from its cache. How you do that depends on the browser you're using.

squawk7000
Posts: 5
Joined: Wed Nov 04, 2015 8:01 pm

Re: Missing silhoutes and flags.

Post by squawk7000 » Sat Nov 07, 2015 11:46 am

Got it working

Thanks for your help.

squawk7000

Ken355
Posts: 6
Joined: Mon Nov 09, 2015 1:50 am

Re: Missing silhoutes and flags.

Post by Ken355 » Mon Nov 09, 2015 2:10 am

Hello,

I too have the same issue. I can now get silhouettes to display, but no flags.

I put the flags in a directory called "C:\Kinetic\BaseStation\OperatorFlags". The VRS datasource points to this folder. Inside this are two more directories, called "_MACOSX" and "Country Flags", which contains other folders such as "small_flags", "small_mil_dark", "wide_civil", and others. The actual flag icons are .bmp files with the name of the country as the file name. There is also a "CountriesDAT" folder which contains a file called "Countries.dat".

Should I be able to point the VRS file to the OperatorFlags folder and have it find what it needs? Will the VRS program look inn any and all subdirectories? I tried pointing to various directories, but no luck in displaying any country flags. Maybe the flag files are not correct for VRS?

Ken
USA

Post Reply