Slugish Performance

Discussions about the preview versions of Virtual Radar Server.
Forum rules
Please bear in mind if you do install a preview version that it is unfinished code, there may be bugs, bits missing, things that don't work etc.

Posts in this forum will not show up in forum search results. Old threads will be pruned occasionally.
Post Reply
shish0r
Posts: 9
Joined: Sat Mar 30, 2013 7:14 pm

Slugish Performance

Post by shish0r » Sat Feb 10, 2018 1:20 pm

Hi Andrew and all,

I've swapped over to using the preview version from 4th Feb and I wondered if I'm not the only one who is finding that there seems to be significant additional workload on the browser/client side since the last stable release? For me, this is making things appear quite sluggish (both the map display and the aircraft list where scrolling becomes a bit rubbish) when there are a reasonable number of aircraft showing. I often have >200 aircraft showing, with permanent long trails. Reducing the number of aircraft on the map display does have a significant impact on the load. I tend to use google Chrome under windows 10 on two PC's both with reasonable specs (core i7 from a couple of generations back and a core-M). Looking at the server side things look nice and calm though, with no obvious increase in load (running very happily under win10 on a first gen i5).

Am I the only one? Is there an obvious reason for this? I must admit I was quite taken aback at this as VRS used to perform very well client side before with only very very minor sluggishness on the map display when things got really busy (>250). I presume something has changed in the rendering? The text on the map display certainly looks a lot 'sharper' than before?

Cheers

Andy

shish0r
Posts: 9
Joined: Sat Mar 30, 2013 7:14 pm

Re: Slugish Performance

Post by shish0r » Sun Feb 11, 2018 8:48 am

Just to add a bit of detail from this morning with about 160 aircraft displaying. It takes about 2 seconds for the aircraft list to react to a scroll up or down request with a single aircraft label for each aircraft on the map display. Removing the aircraft labels helps significantly and brings this down to perhaps half to 1 second delay.

Cheers

Andy

P.S. Not wanting to be critical at all of free software! Just trying to understand and help if the change in performance is accidental.

shish0r
Posts: 9
Joined: Sat Mar 30, 2013 7:14 pm

Re: Slugish Performance

Post by shish0r » Sun Feb 11, 2018 12:45 pm

After playing round it now looks like a Chrome hardware acceleration issue as when I turn this off things improve significantly.

Andy

agw
Posts: 2058
Joined: Fri Feb 17, 2012 3:20 am

Re: Slugish Performance

Post by agw » Sun Feb 18, 2018 11:37 pm

V3 introduces SVG graphics, which in the preview are switched on by default. SVG graphics involve the browser drawing the aircraft markers as vector graphics, whereas the old bitmap markers were fetched them from the server (which pushed the burden of creating the images onto the server). Drawing SVG markers could be particularly punishing for old mobile devices if you have a large number of aircraft.

However, you can switch SVG on and off in the web site settings. You can now also switch SVG on for the desktop and off for mobile. The advantage with SVG is that (eventually) the markers will look nice and sharp on high DPI devices, you get proper markers under Mono instead of that crappy black box with the marker text underneath each marker and the server workload is decreased. The disadvantage is the browser has more work to do.

Post Reply