Page 1 of 1

[Solved] Sourcecode - TypeScript Errors

Posted: Sun Dec 24, 2017 3:15 pm
by Datamix
I tried to build VRS using the sourcecode. But I got a lot of TypeScript erros such as:
  • TS2503
  • TS2504
  • TS2511
  • TS2522
  • TS2545
  • TS2559

Therefore I can't build the program.

I'm using:

Visual Studio 2017 Enterprise
TypeScript 2.5

Re: [Solved] Sourcecode - TypeScript Errors

Posted: Mon Jan 08, 2018 3:33 pm
by Datamix
I don't know why but uninstalling the integrated TypeScript Version (2.5.3) and installing Version 2.6.2 over NPM worked.

Re: [Solved] Sourcecode - TypeScript Errors

Posted: Sat Jan 20, 2018 1:17 am
by agw
Visual Studio is a pain in the backside with TypeScript versions, it's a new version every month and each one has breaking changes. They need to calm down, and also take backwards compatibility more seriously.

I have pinned the version of TypeScript to version 2.3 in the latest source in master, although there's something up with the custom content plugin's csproj that is stopping it from picking up the setting at the moment. Once I've got the pinning working then I'll update it to 2.5.

Re: [Solved] Sourcecode - TypeScript Errors

Posted: Sat Jan 20, 2018 6:45 pm
by Datamix
Good to hear I'm not the only one struggling with TypeScript and Visual Studio.