Latest preview on Ubuntu 16.04.4 crashes

Discussions about the preview versions of Virtual Radar Server.
Forum rules
Please bear in mind if you do install a preview version that it is unfinished code, there may be bugs, bits missing, things that don't work etc.

Posts in this forum will not show up in forum search results. Old threads will be pruned occasionally.
Post Reply
magic51
Posts: 3
Joined: Wed Jun 06, 2018 2:57 pm

Latest preview on Ubuntu 16.04.4 crashes

Post by magic51 » Wed Jun 06, 2018 3:05 pm

Hi!

Setting up a new server on Linux. 2.4 version works fine but when trying the preview version i get a Unhandled Exception Caught.

Running Ubuntu 16.04.4 LTS with Mono JIT compiler version 4.2.1 (Debian 4.2.1.102+dfsg2-7ubuntu4).

Starting with the workingFolder option to not "disturb" the working 2.4.

mono /usr/bin/vrsbeta/VirtualRadar.exe -nogui -workingFolder:/home/adminuser/.local/share/VirtualRadarBeta

Any ideas what goes wrong? I totally understand its a preview version but perhaps its something simple (im missing)?

Also thanks for the great work with this piece of software!

Code: Select all

Unhandled Exception Caught
System.MissingMethodException: Method 'Array.Empty' not found.
  at VirtualRadar.Owin.Configuration.WebAppConfiguration.Configure (IAppBuilder appBuilder) <0x40bc2380 + 0x00199> in <filename unknown>:0
  at VirtualRadar.Owin.LoopbackHost.ConfigureCustomPipeline (IWebAppConfiguration webAppConfiguration) <0x40bbd6a0 + 0x00032> in <filename unknown>:0
  at VirtualRadar.Owin.LoopbackHost.ConfigureStandardPipeline () <0x40bb6f70 + 0x00057> in <filename unknown>:0
  at VirtualRadar.WebSite.WebSite.AttachSiteToServer (IWebServer server) <0x40b9cfd0 + 0x00347> in <filename unknown>:0
  at VirtualRadar.Library.Presenter.SplashPresenter.StartWebSite () <0x40b980b0 + 0x001c4> in <filename unknown>:0
  at VirtualRadar.Library.Presenter.SplashPresenter.StartApplication () <0x40b1b900 + 0x000cb> in <filename unknown>:0
  at VirtualRadar.Headless.View.SplashView.ShowView () <0x40b1b470 + 0x00085> in <filename unknown>:0
  at VirtualRadar.Interface.ProgramLifetime.StartApplication (System.String[] args) <0x40b1ad10 + 0x00139> in <filename unknown>:0
  at VirtualRadar.Interface.ProgramLifetime.SingleInstanceStart (System.String[] args) <0x40b1a850 + 0x00047> in <filename unknown>:0
  at VirtualRadar.Program.Main (System.String[] args) <0x40b0dd50 + 0x000a7> in <filename unknown>:0

[ERROR] FATAL UNHANDLED EXCEPTION: System.MissingMethodException: Method 'Array.Empty' not found.
  at VirtualRadar.Owin.Configuration.WebAppConfiguration.Configure (IAppBuilder appBuilder) <0x40bc2380 + 0x00199> in <filename unknown>:0
  at VirtualRadar.Owin.LoopbackHost.ConfigureCustomPipeline (IWebAppConfiguration webAppConfiguration) <0x40bbd6a0 + 0x00032> in <filename unknown>:0
  at VirtualRadar.Owin.LoopbackHost.ConfigureStandardPipeline () <0x40bb6f70 + 0x00057> in <filename unknown>:0
  at VirtualRadar.WebSite.WebSite.AttachSiteToServer (IWebServer server) <0x40b9cfd0 + 0x00347> in <filename unknown>:0
  at VirtualRadar.Library.Presenter.SplashPresenter.StartWebSite () <0x40b980b0 + 0x001c4> in <filename unknown>:0
  at VirtualRadar.Library.Presenter.SplashPresenter.StartApplication () <0x40b1b900 + 0x000cb> in <filename unknown>:0
  at VirtualRadar.Headless.View.SplashView.ShowView () <0x40b1b470 + 0x00085> in <filename unknown>:0
  at VirtualRadar.Interface.ProgramLifetime.StartApplication (System.String[] args) <0x40b1ad10 + 0x00139> in <filename unknown>:0
  at VirtualRadar.Interface.ProgramLifetime.SingleInstanceStart (System.String[] args) <0x40b1a850 + 0x00047> in <filename unknown>:0
  at VirtualRadar.Program.Main (System.String[] args) <0x40b0dd50 + 0x000a7> in <filename unknown>:0

agw
Posts: 2146
Joined: Fri Feb 17, 2012 3:20 am

Re: Latest preview on Ubuntu 16.04.4 crashes

Post by agw » Sat Jun 09, 2018 2:04 pm

It's saying that 4.2.1 doesn't have an implementation for Array.Empty. Moving Mono up to a more recent version should do the trick.

magic51
Posts: 3
Joined: Wed Jun 06, 2018 2:57 pm

Re: Latest preview on Ubuntu 16.04.4 crashes

Post by magic51 » Sat Jun 09, 2018 2:40 pm

Aha! Right now it should be Mono that i got via "apt-get" but that seems to be outdated. Current version should be 5.12.0.

Will take a look doing a manual install. Thanks!

magic51
Posts: 3
Joined: Wed Jun 06, 2018 2:57 pm

Re: Latest preview on Ubuntu 16.04.4 crashes

Post by magic51 » Sat Jun 09, 2018 10:17 pm

Upgraded to 5.12 with instructions from mono web-site. https://www.mono-project.com/download/s ... wnload-lin

Working now. Thanks!

Post Reply