Page 1 of 1

V3 bug in SQL Server plugin?

Posted: Fri Aug 23, 2019 9:27 pm
by GeBrander
Hi, I am trying the latest V3 3.0.0 Beta (x64 and x86) and I am having problems with the SQL Server Plugin. I am using SQL Server 2017 (named instance). The connection to the database is working because the Aircraft table is being populated but the Flights table stays empty.
I see in the plugins page an error at the Database Writer Plugin:
  • exception caught: @HadSpi is not a parameter for procedure Flights_Insert
When I check the Flights_Insert procedure in the SQL Server database the @HadSpi parameter does exist! Anyone else having this problem?
Update:
I created an Azure SQL Database and tried to reproduce the problem but there it works as expected. The difference is the version of SQL Server.
  • Microsoft SQL Server 2017 (RTM) - 14.0.1000.169 (X64) Aug 22 2017 17:04:49 Copyright (C) 2017 Microsoft Corporation
  • Microsoft SQL Azure (RTM) - 12.0.2000.8 Jul 3 2019 10:02:53 Copyright (C) 2019 Microsoft Corporation
I will try some extra tests and keep you posted:
  • Install SQL Server 2017 Default instance
  • Install SQL Server 2014

Re: V3 bug in SQL Server plugin?

Posted: Sat Sep 07, 2019 12:25 pm
by agw
Sorry for the late reply. The SQL Server plugin was developed against SS2016, I would expect it to work OK on there :) I'll add this as a github issue so that I don't forget it and then when I get a chance I'll download one of MS's SS2017 docker containers and see if I can reproduce it there.