Merged feed stops feeding when hidden

Is Virtual Radar Server not behaving itself? If so then please report it here.
Post Reply
Radio Active
Posts: 34
Joined: Wed Mar 30, 2016 7:14 am
Contact:

Merged feed stops feeding when hidden

Post by Radio Active » Tue Nov 29, 2016 5:53 am

I'm feeding data on a rebroadcast server to someone but using a select set of receivers, now I've made a merged feed for this and don't want it to appear on the web site, so when I click on "hide feed from web site" the data feed stops to the rebroadcast server and so forth, is there something I missed in the steps or is there a possibility there might be something up.
I've looked at the documentation & setting but can't see that any thing is wrong with the settings and the way I read it is that I should be able to use this hidden merged feed on a rebroadcast server, Have I got it wrong or am half wrong ??

Gary.

agw
Posts: 2241
Joined: Fri Feb 17, 2012 3:20 am

Re: Merged feed stops feeding when hidden

Post by agw » Wed Dec 07, 2016 1:07 am

I can't reproduce this. I tried this:

1. I set up a BaseStation format rebroadcast server for a merged feed that was not flagged as hidden from the web site. The port was 33008.
2. I opened up a web browser on http://127.0.0.1:33008 and confirmed that it showed the messages on the feed (BaseStation format is a plain text format).
3. I went back into the options and ticked the box on the merged feed to say that it's hidden from the web site. Clicked OK to save the options.
4. Opened the browser on the same address as before and it showed me the messages on the feed.
5. I started up a new browser and tried from there, just in case the old one was holding a connection open. It showed the messages.
6. I quit VRS and restarted to see if it only happens if the merged feed is flagged as hidden from the web site on startup. The browser still showed the messages.

If you can give me a bit more information about the receivers being merged and how the merged feed has been configured then I can try to reproduce it... but in answer to your question, you're correct, hiding a merged feed from the web site should not stop it from being used as a source for a rebroadcast server. If that's what's happening then it's a bug.

Radio Active
Posts: 34
Joined: Wed Mar 30, 2016 7:14 am
Contact:

Re: Merged feed stops feeding when hidden

Post by Radio Active » Sat Dec 17, 2016 3:54 am

OK did more checks on my end to see if it maybe the input feeds formats, but I'm unable to perform output format due to person being away.

Operating system Windows 8,
VRS version V2.4.

RX 1 receiver format (AVR acsii)
RX 2 receiver format (aircraft list json)
RX 3 receiver format (BaseStation)

Rebroadcast server output format (aircraft list json)

Now it all works a charm and sends data from all 3 receivers when visible, but it stops sending data when hidden.
I did try isolating receivers from the rebroadcast server but it didn't make a difference for me.

Gary.

Radio Active
Posts: 34
Joined: Wed Mar 30, 2016 7:14 am
Contact:

Re: Merged feed stops feeding when hidden

Post by Radio Active » Sat Dec 17, 2016 4:18 am

I was able to hijack my Daughters laptop and installed VRS and did in house checks.

I found it is an output data format that is causing the data to stop when merged feed is hidden.

Data sends OK using Base Station, Compressed VRS, and Base Station + MLAT, but as soon as "aircraft list json" on rebroadcast server is selected it stops sending data when merged feed is hidden but works on visible.
I'm on an ADSL internet connection here really good download but limited upload bandwidth and used json as it has the least amount of data bandwidth which suited me perfectly.

Gary.

agw
Posts: 2241
Joined: Fri Feb 17, 2012 3:20 am

Re: Merged feed stops feeding when hidden

Post by agw » Thu Dec 22, 2016 1:45 am

I've had a go at reproducing it with a AircraftList (JSON) rebroadcast server of a merged feed and it's still working for me when the merged feed is hidden from the web site.

Are all of the receivers that are being merged flagged as hidden from the web site or merge only?

Radio Active
Posts: 34
Joined: Wed Mar 30, 2016 7:14 am
Contact:

Re: Merged feed stops feeding when hidden

Post by Radio Active » Mon Dec 26, 2016 3:30 am

All of the receivers in question are visible.
I checked to see one by one plus multiple receivers if making a receiver hidden or merged made a difference but it didn't in my case.

agw
Posts: 2241
Joined: Fri Feb 17, 2012 3:20 am

Re: Merged feed stops feeding when hidden

Post by agw » Sat Dec 31, 2016 1:50 am

I've been testing using the latest version of the source, so one possibility could be that I can't reproduce the problem because I've already fixed it. I don't remember fixing anything like that :) But you never know.

If you could have a go with the latest preview version (http://www.virtualradarserver.co.uk/Preview.aspx) and see if it still happens I'd appreciate it. I'll be uploading another preview some time over the weekend but the one that's there now isn't too far behind the current source, most of the work in the past month was on the SDM site rather than VRS.

Post Reply