VRS connecting to piaware mlat-client causes SYN flooding

Is Virtual Radar Server not behaving itself? If so then please report it here.
Post Reply
Jester
Posts: 54
Joined: Tue Apr 09, 2013 6:23 pm

VRS connecting to piaware mlat-client causes SYN flooding

Post by Jester » Mon Feb 20, 2017 4:34 pm

Hi,

I'm running piaware on a Pi3 with an airspy feeding it, I use VRS to connect back to the mlat-client to get back MLAT positions, however
even when the connection status is connected in VRS i'm getting no data back, on checking on the Pi3 I noticed this:
[ 431.885108] TCP: request_sock_TCP: Possible SYN flooding on port 31003. Sending cookies. Check SNMP counters.

This used to work fine, but something has changed on either raspbian or VRS.

I've already tried:
sudo sysctl -w net.ipv4.tcp_max_syn_backlog=65536
sudo sysctl -w net.ipv4.tcp_syncookies=0
without luck.

Could you have a look to see why VRS is causing SYN flooding ? could you lower the reconnects maybe ?

Thanks
P.S.
I'm running the latest preview.

Jester
Posts: 54
Joined: Tue Apr 09, 2013 6:23 pm

Re: VRS connecting to piaware mlat-client causes SYN flooding

Post by Jester » Mon Feb 20, 2017 5:55 pm

to bypass the SYN flooding issue i tried making it a push server:

sudo piaware-config mlat-results-format "beast,connect,server:31003"

It says connected but no data (messages or tracked aircraft)

Before you ask, yes i'm receiving stuff:

02/20/2017 17:40:59 mlat-client(748): Receiver status: connected
02/20/2017 17:40:59 mlat-client(748): Server status: synchronized with 173 nearby receivers
02/20/2017 17:40:59 mlat-client(748): Receiver: 1906.1 msg/s received 226.1 msg/s processed (12%)
02/20/2017 17:40:59 mlat-client(748): Server: 0.0 kB/s from server 0.0kB/s TCP to server 2.3kB/s UDP to server
02/20/2017 17:40:59 mlat-client(748): Aircraft: 31 of 68 Mode S, 48 of 102 ADS-B used
02/20/2017 17:41:29 8046 msgs recv'd from airspy_adsb (2715 in last 5m); 8046 msgs sent to FlightAware
02/20/2017 17:46:29 10780 msgs recv'd from airspy_adsb (2734 in last 5m); 10780 msgs sent to FlightAware


Any clue ??

Jester
Posts: 54
Joined: Tue Apr 09, 2013 6:23 pm

Re: VRS connecting to piaware mlat-client causes SYN flooding

Post by Jester » Mon Feb 20, 2017 6:03 pm

Update, on a whim I disabled the windows 7 firewall, and voila it works, which is strange it VRS is in the accept list.

I've created 2 rules for the MLAT port (31003 in my case) one for TCP and one for UDP and that seemed to have done the trick.

Thing that remains in the SYN Flood if I remove the push server...

strange.

agw
Posts: 2249
Joined: Fri Feb 17, 2012 3:20 am

Re: VRS connecting to piaware mlat-client causes SYN flooding

Post by agw » Sun Feb 26, 2017 7:03 pm

When you have it running as a receiver and you're getting the syn flood thing on the Linux side, do you see any messages in the connector activity log in VRS for the receiver? You can see the log by going to Tools | Open Connector Activity Log and then choose the appropriate receiver in the Connector drop-down list.

Jester
Posts: 54
Joined: Tue Apr 09, 2013 6:23 pm

Re: VRS connecting to piaware mlat-client causes SYN flooding

Post by Jester » Wed Mar 08, 2017 12:57 pm

Sorry for the late reply, I will have a look tonight.

Post Reply