Aircraft photos not showing

Is Virtual Radar Server not behaving itself? If so then please report it here.
jepolch
Posts: 11
Joined: Wed May 06, 2015 4:43 pm

Re: Aircraft photos not showing

Post by jepolch »

Raffles wrote: Thu Mar 05, 2020 9:08 am
jepolch wrote: Wed Mar 04, 2020 7:42 pm
Raffles wrote: Wed Mar 04, 2020 9:37 am JFYI - same in v2.4.3

gonna try a re-install of 244 later...

UPDATE:complete re-install doesn't fix it :(
Thanks for trying. I guess 2.4.4. is still pointing at planebase.biz and they've cut us off.
it's actually nothing to do with planebiz - that was me reading it wrong... airport-data.com are the culprits this time...
That's what I originally thought.
Raffles
Posts: 29
Joined: Thu Nov 16, 2017 3:34 pm

Re: Aircraft photos not showing

Post by Raffles »

JSON from airport-data.com:


{"status":200,"count":21,"data":[{"image":"\/images\/aircraft\/thumbnails\/001\/540\/001540908.jpg","link":"\/aircraft\/photo\/001540908.html","photographer":"micka2b"},{"image":"\/images\/aircraft\/thumbnails\/001\/406\/001406157.jpg","link":"\/aircraft\/photo\/001406157.html","photographer":"FerryPNL"},{"image":"\/images\/aircraft\/thumbnails\/001\/397\/001397052.jpg","link":"\/aircraft\/photo\/001397052.html","photographer":"Clayton Eddy"},{"image":"\/images\/aircraft\/thumbnails\/001\/397\/001397049.jpg","link":"\/aircraft\/photo\/001397049.html","photographer":"Clayton Eddy"},{"image":"\/images\/aircraft\/thumbnails\/001\/396\/001396983.jpg","link":"\/aircraft\/photo\/001396983.html","photographer":"Clayton Eddy"},{"image":"\/images\/aircraft\/thumbnails\/001\/396\/001396981.jpg","link":"\/aircraft\/photo\/001396981.html","photographer":"Clayton Eddy"},{"image":"\/images\/aircraft\/thumbnails\/001\/385\/001385905.jpg","link":"\/aircraft\/photo\/001385905.html","photographer":"Clayton Eddy"},{"image":"\/images\/aircraft\/thumbnails\/001\/385\/001385901.jpg","link":"\/aircraft\/photo\/001385901.html","photographer":"Clayton Eddy"},{"image":"\/images\/aircraft\/thumbnails\/001\/385\/001385900.jpg","link":"\/aircraft\/photo\/001385900.html","photographer":"Clayton Eddy"},{"image":"\/images\/aircraft\/thumbnails\/001\/385\/001385896.jpg","link":"\/aircraft\/photo\/001385896.html","photographer":"Clayton Eddy"},{"image":"\/images\/aircraft\/thumbnails\/001\/385\/001385895.jpg","link":"\/aircraft\/photo\/001385895.html","photographer":"Clayton Eddy"},{"image":"\/images\/aircraft\/thumbnails\/001\/385\/001385890.jpg","link":"\/aircraft\/photo\/001385890.html","photographer":"Clayton Eddy"},{"image":"\/images\/aircraft\/thumbnails\/001\/385\/001385860.jpg","link":"\/aircraft\/photo\/001385860.html","photographer":"Clayton Eddy"},{"image":"\/images\/aircraft\/thumbnails\/001\/172\/001172452.jpg","link":"\/aircraft\/photo\/001172452.html","photographer":"Ray Barber"},{"image":"\/images\/aircraft\/thumbnails\/001\/172\/001172451.jpg","link":"\/aircraft\/photo\/001172451.html","photographer":"Ray Barber"},{"image":"\/images\/aircraft\/thumbnails\/001\/097\/001097351.jpg","link":"\/aircraft\/photo\/001097351.html","photographer":"Jerzy Maciaszek"},{"image":"\/images\/aircraft\/thumbnails\/000\/905\/905872.jpg","link":"\/aircraft\/photo\/000905872.html","photographer":"FerryPNL"},{"image":"\/images\/aircraft\/thumbnails\/000\/784\/784897.jpg","link":"\/aircraft\/photo\/000784897.html","photographer":"Holger Zengler"},{"image":"\/images\/aircraft\/thumbnails\/000\/355\/355503.jpg","link":"\/aircraft\/photo\/000355503.html","photographer":"Philippe Bleus"},{"image":"\/images\/aircraft\/thumbnails\/000\/355\/355091.jpg","link":"\/aircraft\/photo\/000355091.html","photographer":"Daniel Vanderauwera"},{"image":"\/images\/aircraft\/thumbnails\/000\/327\/327497.jpg","link":"\/aircraft\/photo\/000327497.html","photographer":"Michel Teiten ( www.mablehome.com )"}]}

if you notice - no http://www.airport-data.comin the image links etc... if it's added to the front - it should work ;) I tried it - but vrs craps out due to the change in the file(s) #oneforandrew
DeWoert
Posts: 42
Joined: Mon Feb 29, 2016 9:36 pm

Re: Aircraft photos not showing

Post by DeWoert »

Seems to be working again here ;)
jepolch
Posts: 11
Joined: Wed May 06, 2015 4:43 pm

Re: Aircraft photos not showing

Post by jepolch »

Big thanks to the devs for fixing the photos issue! I heard the unique sound of an antique plane flying over my house this morning. I ran inside to check my VRS and was rewarded with this sight! N9079Z, 1944 North American TB-25N Mitchell

https://imgur.com/pRU2i8f
Raffles
Posts: 29
Joined: Thu Nov 16, 2017 3:34 pm

Re: Aircraft photos not showing

Post by Raffles »

looks like airport-data have regressed the API change :)
Raffles
Posts: 29
Joined: Thu Nov 16, 2017 3:34 pm

Re: Aircraft photos not showing

Post by Raffles »

back again...
metalXtractor
Posts: 3
Joined: Wed Jun 27, 2018 10:53 am

Re: Aircraft photos not showing

Post by metalXtractor »

Ok so it's not just me then... was about to open a new topic but google 1 comes to the rescue.
Absolutely no change from my side since many years.

Using default runtime: v4.0.30319
hell knows what version this is.
a66e79b1a3740584a600958404b46d01 VirtualRadar.exe

I also see this on the console:

Code: Select all

libpng warning: iCCP: known incorrect sRGB profile
libpng warning: iCCP: cHRM chunk does not match sRGB
libpng warning: iCCP: known incorrect sRGB profile
libpng warning: iCCP: cHRM chunk does not match sRGB
libpng warning: iCCP: known incorrect sRGB profile
libpng warning: iCCP: cHRM chunk does not match sRGB
libpng warning: iCCP: known incorrect sRGB profile
libpng warning: iCCP: cHRM chunk does not match sRGB

This is what I just hate about the "cloud" in general that they always screw around with APIs or even disable complete services, that's what happened to WeatherUnderground was great for about 6 years :(
SingingDwarf
Posts: 12
Joined: Wed Jul 17, 2013 3:10 pm

Re: Aircraft photos not showing

Post by SingingDwarf »

Are you running on mono? I have the same issue running on mono.
No fix as yet.
Raffles
Posts: 29
Joined: Thu Nov 16, 2017 3:34 pm

Re: Aircraft photos not showing

Post by Raffles »

win
SingingDwarf
Posts: 12
Joined: Wed Jul 17, 2013 3:10 pm

Re: Aircraft photos not showing

Post by SingingDwarf »

?
Post Reply