Page 4 of 4

Re: Aircraft photos not showing

Posted: Mon Dec 27, 2021 9:57 pm
by metalXtractor

Code: Select all

ii  mono-4.0-gac                                                5.18.0.240+dfsg-3                   all          Mono GAC tool (for CLI 4.0)
ii  mono-csharp-shell                                           5.18.0.240+dfsg-3                   all          interactive C# shell
ii  mono-devel                                                  5.18.0.240+dfsg-3                   all          Mono development tools
ii  mono-gac                                                    5.18.0.240+dfsg-3                   all          Mono GAC tool
ii  mono-mcs                                                    5.18.0.240+dfsg-3                   all          Mono C# 2.0 / 3.0 / 4.0 / 5.0  compiler for CLI 2.0 / 4.0 / 4.5
ii  mono-runtime                                                5.18.0.240+dfsg-3                   armhf        Mono runtime - default version
ii  mono-runtime-common                                         5.18.0.240+dfsg-3                   armhf        Mono runtime - common files
ii  mono-runtime-sgen                                           5.18.0.240+dfsg-3                   armhf        Mono runtime - SGen
ii  mono-xbuild                                                 5.18.0.240+dfsg-3                   all          MSBuild-compatible build system for Mono
ii  mono-xsp4                                                   4.2-2.1                             all          simple web server to run ASP.NET 4.0 applications
ii  mono-xsp4-base                                              4.2-2.1                             all          base libraries for XSP 4.0
Yeah of course that I run it with mono I run it on a Raspberry PI.

A version would be nice which would locally store the aircraft images, 32, 64gb sdcards are dirt cheap these days and then we wouldn't even need an external connection from this app.

Re: Aircraft photos not showing

Posted: Sat Jan 22, 2022 5:54 pm
by n8mdp
Looks like I'm having the same problems. Pictures not showing up. I learned that my account on airport-data.com has been inactivated. Nice how they just made it inactive. I can't even recover my password with them right now. But that's another story. When I reviewed one of the on-line sites on VRS, http://myplanes2.ddns.net:8081/VirtualRadar, also known as the SuperChicken Lake Michigan site, I noticed this server has a number of sources for photos:

JetPhotos : : Planespotters : : OneSpotter : : ADS-B Exchange : : TrafegoAereo : : FlightAware : : Serial (FAA) : : N Number (FAA) : : RAB (ANAC) : : JakaFotografia : : PilotoDeAvi√£o : : Flickr : : Google : : AirTeamImages : : LKPDinfo : : AviationCorner : : PlaneSpotersHub : : Eurocontrol : : www.airliners.net : : www.jetphotos.com

So how do you edit VRS to add more photo sources? What is the process to add these sources so I can add them to my server, which is http://n8mdp.ddns.net:8085/VirtualRadar/desktop.html#

I appreciate help here.

Re: Aircraft photos not showing

Posted: Sun Jan 23, 2022 7:08 am
by Holytux
The pictures from the various websites are stored locally at "SuperChicken Lake Michigan" and are not automatically retrieved by the VRS.
If you move the mouse over the pictures, you will see the local address. I do it that way too, it's just a "hard work"... ;) (http://92.206.168.125:8080/VirtualRadar/desktop.html). But then a picture of "Air Berlin" or something similar doesn't suddenly appear.
With the appropriate programming knowledge, there are certainly other possibilities. Unfortunately, I have too little idea... :|

Greetings

Re: Aircraft photos not showing

Posted: Sun Jan 23, 2022 1:35 pm
by n8mdp
Holytux, thanks for answering some of my questions. OK, so I can certainly start collecting my own pictures and creating a group of images locally. Hard work but doable. I've started to create my own BaseStation.sqb file to have the most recent data collected for what goes on here. I assume I can open that file in the right tool to see all of the planes that have been detected over time to help build my picture database. But I do have some other questions that maybe you can answer.

1. How do you add the other links like I mentioned in my posting to the window so you users can click them to see the images from those sites?
2. What happened to the ability for pictures to be displayed automatically from airport-data.com? Did they just stop allowing VRS to display pictures automatically from their site? I saw in some of the threads about changes to the API from airport-data.com. Is there anything that can be done to restore my site to still use airport-data.com to display pictures?
3. Is there a set of documentation to explain how to set up pictures locally so they can be displayed? I can take it from there.

Thanks for the help.
N8MDP

Re: Aircraft photos not showing

Posted: Tue Jan 25, 2022 11:17 pm
by n8mdp
I had a problem with my PC running VR server 2.4.4. So I switched it back to another computer running version 2.4.3 and now the images show up again. So there must be something with version 2.4.4 that is preventing the images from appearing. So I am sticking with version 2.4.3.

If it ain't broke, don't fix it!

Re: Aircraft photos not showing

Posted: Fri Feb 11, 2022 1:16 pm
by baldjake
Been running 2.4.4 mono version on an old Linux Mint 18.3 32-bit version and was working fine. Had to use that machine for another purpose so decided to run VRS on a Raspberry Pi 3b+ running Buster and now the photo downloads will not work. I tried the 2.4.5-Preview 5 and that that crashes immediately. 3.0.0-Preview 6 runs but photos still don't download. Same dongle and antenna (the machines are right next to each other) and the same network connection (ethernet to the same router.) Both machines are running Dump-1090 although slightly different - the Mint 18.3 is compiled from Ted Sluis fork of the mutability version, but the Pi is running the repo's version of mutability (the Sluis fork would not compile properly.) I wanted to try the 2.4.3 version but can't find a copy of it anywhere - even what is on archive.org is just a link that points to the location of the current 2.4.4 download so is not helpful.

Re: Aircraft photos not showing

Posted: Mon Feb 21, 2022 8:58 pm
by metalXtractor
Seems like sadly this project is getting abandoned:


Version 2.4.4
20th December 2019


No new version, I wonder if any1 come up with a workaround to have the plane pictures fixed. The one was suggested here no idea what that rambling is about as you never had to register to any sites or datafeeds for this project to have that working.

Do you guys have any alternatives for this, something which preferably runs on Linux and raspberry PI? :?:

Re: Aircraft photos not showing

Posted: Tue Feb 22, 2022 9:13 am
by metalXtractor
I have looked into this more at night and ran tcpdump on the vradar server.

It tries to connect here:

curl -k 'https://www.airport-data.com/api/ac_thu ... ODE&r=&n=2'

Which should report something like:

Code: Select all

 curl -k 'https://www.airport-data.com/api/ac_thumb.json?m=PLANECODE&r=&n=2'
{"status":200,"count":1,"data":[{"image":"https:\/\/cdn.airport-data.com\/images\/aircraft\/thumbnails\/001\/XYZ\/PLANECODE.jpg","link":"https:\/\/www.airport-data.com\/aircraft\/photo\/PLANECODE.html","photographer":"Raymond Zammit"}]}
What's strange that this host doesn't even work many times from my regular PC...

They should at least put it behind some CDN as it seems to be a single webserver. The other thing is why is the VRADAR server try to prefetch this image instead of just putting a link in the datastream and let our browsers load it directly.

Anyway it would be nice to cooperate with the owner of this site to provide all plane pictures in a tarball and find a way to locally add it in the vradar.