Bugs in 2.0.1

Is Virtual Radar Server not behaving itself? If so then please report it here.
Sentry_e3
Posts: 81
Joined: Wed May 15, 2013 11:57 pm

Re: Bugs in 2.0.1

Post by Sentry_e3 » Fri Mar 21, 2014 8:49 am

agw wrote:The site doesn't use cookies any more, it uses local storage. Do you have private browsing switched on?
No i'm not using the private browsing. On firefox on my PC the settings have been kept at the 1st attempt but on the ipad, after just a reload of the webpage, the default settings are back

agw
Posts: 2248
Joined: Fri Feb 17, 2012 3:20 am

Re: Bugs in 2.0.1

Post by agw » Fri Mar 21, 2014 11:30 pm

It's working fine on my iPad in Chrome and Mobile Safari. If you go to the settings.html page of the site on the iPad what does it say for storage engine and storage size?

Sentry_e3
Posts: 81
Joined: Wed May 15, 2013 11:57 pm

Re: Bugs in 2.0.1

Post by Sentry_e3 » Sat Mar 22, 2014 8:24 am

Hum where can i find this settings.html page?

agw
Posts: 2248
Joined: Fri Feb 17, 2012 3:20 am

Re: Bugs in 2.0.1

Post by agw » Sat Mar 22, 2014 3:58 pm

Replace "mobile.html" with "settings.html" in the browser's address bar. Alternatively the full address can be displayed in VRS - select "Settings Page" from the second dropdown list on the main server screen.

Sentry_e3
Posts: 81
Joined: Wed May 15, 2013 11:57 pm

Re: Bugs in 2.0.1

Post by Sentry_e3 » Sat Mar 22, 2014 7:13 pm

I send you a MP

Jester
Posts: 54
Joined: Tue Apr 09, 2013 6:23 pm

Re: Bugs in 2.0.1

Post by Jester » Sun Mar 23, 2014 11:32 am

When you have setup VRS with multiple feeds plus a merged feed and you access the website and then you switch back to a single receiver single feed in VRS setup (on the server side) and go to the website you wont get any aircraft tracked, this seems to be due to the local storage still remembering the merged feed but not switching back to the single feed (nor can you select this from the interface)

Could you "overwrite" the local storage on each web viewing session so the correct receiver/merged feed is taken into account ?

Cheers :)

agw
Posts: 2248
Joined: Fri Feb 17, 2012 3:20 am

Re: Bugs in 2.0.1

Post by agw » Sun Mar 23, 2014 10:29 pm

The web site does record the feed last used and uses that for the next session, but if the feed no longer exists then it switches back to the default feed. Does the merged feed still exist on the server?

Jester
Posts: 54
Joined: Tue Apr 09, 2013 6:23 pm

Re: Bugs in 2.0.1

Post by Jester » Mon Mar 24, 2014 7:12 am

agw wrote:The web site does record the feed last used and uses that for the next session, but if the feed no longer exists then it switches back to the default feed. Does the merged feed still exist on the server?
No,it was removed

oh-bomm
Posts: 6
Joined: Sun Oct 27, 2013 6:15 pm
Location: EFKK

Re: Bugs in 2.0.1

Post by oh-bomm » Mon Mar 24, 2014 9:18 am

Found an intresting thing on my VRS 2.0.1.

Take for example SAS006 /sk006 = SAS6/SK6 (ARN - LLA)

In the radar view it get it right
radar_view.jpg
Radar View
radar_view.jpg (138.18 KiB) Viewed 3799 times
But on the report page there the SAS006 not getting the route ARN-LLA correctly as all the other SAS0XX starting calsigns,
report_view.jpg
Report view
report_view.jpg (116.91 KiB) Viewed 3799 times
they are gone
***********************************************************************
You learn everyday something new

agw
Posts: 2248
Joined: Fri Feb 17, 2012 3:20 am

Re: Bugs in 2.0.1

Post by agw » Thu Mar 27, 2014 12:32 am

I think the reports aren't trying all permutations of callsign when looking for routes - I'll add it to the list :)

Locked