Could not load Google Maps within 5000ms.

Is Virtual Radar Server not behaving itself? If so then please report it here.
alezjig
Posts: 11
Joined: Wed Dec 03, 2014 10:29 am
Location: Anadyr

Could not load Google Maps within 5000ms.

Post by alezjig » Wed Dec 03, 2014 10:53 am

Hi.
Starting with version 2 of VRS, there was a problem with downloading Google maps and locking operation of the site.
I have satellite internet 2Mbps, ping from 550 to 1500ms. See. Screenshot of the problem.
This can be corrected in the next version?


p.s. Sorry for my English.
Attachments
couldnot.jpg
Could not load Google Maps within 5000ms
couldnot.jpg (91.31 KiB) Viewed 3866 times
Hello, from frozen people!

jonfear
Posts: 365
Joined: Sat Feb 09, 2013 12:15 pm
Location: Wick St Lawrence
Contact:

Re: Could not load Google Maps within 5000ms.

Post by jonfear » Wed Dec 03, 2014 4:24 pm

Hi Alezjig

We use satellite broadband at work. This is a common problem and I doubt if Andrew can do much to improve things.

We saw this problem occasionally when we were using Googlemaps. We now use Open Street Maps but still see map tiles not loading correctly. We are on the Ka band satellites with 10Mb down and 2Mb up. It is something to do with the ping times. Unfortunately you cannot change the physics of this, the satellite are a long way up in orbit and it takes time to do the up and down hop!

Not good news, sorry. Perhaps you could try to use just the map instead of the satellite image? That should improve loading times.

Best wishes

Jon
http://www.360radar.co.uk, the new name for MLAT Radar in the UK and Western Europe.

Former PP feeder Bm. No longer feeding. I do not have time to sort out imaginary problems with NTP
when it has been working fine for 2+ Years.

alezjig
Posts: 11
Joined: Wed Dec 03, 2014 10:29 am
Location: Anadyr

Re: Could not load Google Maps within 5000ms.

Post by alezjig » Thu Dec 04, 2014 10:54 am

We have this problem appears 8 times out of 10.
That is, If you clear your browser's cache, this problem will be 100%. This problem is all the people in my area (satellite internet) 2 version of VRS.
I switched the settings on ROADMAPS, will observe.
BUT! Previously, this was not a problem.
Hello, from frozen people!

alezjig
Posts: 11
Joined: Wed Dec 03, 2014 10:29 am
Location: Anadyr

Re: Could not load Google Maps within 5000ms.

Post by alezjig » Mon Dec 08, 2014 4:42 am

On ROADMAPS also error.
VRS 2.0.3 Beta.
Hello, from frozen people!

jonfear
Posts: 365
Joined: Sat Feb 09, 2013 12:15 pm
Location: Wick St Lawrence
Contact:

Re: Could not load Google Maps within 5000ms.

Post by jonfear » Mon Dec 08, 2014 11:18 pm

Hi Alezjig

Can you try the full release of v2.1.0 which you can download from the main VRS website? It may make a difference as it is the full release code...

Cheers

Jon
http://www.360radar.co.uk, the new name for MLAT Radar in the UK and Western Europe.

Former PP feeder Bm. No longer feeding. I do not have time to sort out imaginary problems with NTP
when it has been working fine for 2+ Years.

agw
Posts: 2241
Joined: Fri Feb 17, 2012 3:20 am

Re: Could not load Google Maps within 5000ms.

Post by agw » Tue Dec 09, 2014 12:14 am

Yes, sorry, I meant to reply to this thread - I bumped the timeout up to 20 or 30 seconds from 5 seconds for the release, hopefully that should give it enough time to load.

CharlieAlpha
Posts: 63
Joined: Sat Mar 15, 2014 6:41 pm

Re: Could not load Google Maps within 5000ms.

Post by CharlieAlpha » Fri Dec 12, 2014 7:41 pm

Hi Andrew

Is this any way to configure/customise the time out period?

I often use VRS offline to view reports without being connected to the net - having to wait 30000ms for the load to time out is a bit of pain.

Charlie

agw
Posts: 2241
Joined: Fri Feb 17, 2012 3:20 am

Re: Could not load Google Maps within 5000ms.

Post by agw » Sun Dec 14, 2014 11:39 pm

Not at the moment - however, you can skip the timeout altogether by adding the query string notOnline=1 to the URL, e.g.:

http://127.0.0.1/VirtualRadar/desktop.html?notOnline=1

or

http://127.0.0.1/VirtualRadar?notOnline=1

This stops the site from even attempting to load Google Maps and goes straight to offline mode.

CharlieAlpha
Posts: 63
Joined: Sat Mar 15, 2014 6:41 pm

Re: Could not load Google Maps within 5000ms.

Post by CharlieAlpha » Wed Dec 17, 2014 7:50 pm

Thanks Andrew

I remembered about the offline option after I had posted the question but I was hoping there was a global option I could set. I tried setting
VRS.globalOptions.scriptManagerTimeout = 5000
in the hope that would cut the timeout back down to 5 secs but it didn't seem to make any difference.

As an alternative to making the timeout a configuration item could you add the offline url as an option in the "version" dropdown list? It's probably just me but I tend to start the server then click the link on the server dialog box to start the client/webpage.

Thanks

Charlie

agw
Posts: 2241
Joined: Fri Feb 17, 2012 3:20 am

Re: Could not load Google Maps within 5000ms.

Post by agw » Thu Dec 18, 2014 12:24 am

I would have thought that you should be able to set the timeout like that... looking at the code I'm not seeing anything immediately obvious as to why you couldn't. Which event are you setting the value from?

Yes, it wouldn't hurt to have a tickbox or something on there to add the query string - I'll add it to the list.

Post Reply