Bugs in 2.2.0

Is Virtual Radar Server not behaving itself? If so then please report it here.
Posts: 2249
Joined: Fri Feb 17, 2012 3:20 am

Re: Bugs in 2.2.0

Post by agw » Wed Oct 21, 2015 1:48 am

If you take a look in the log (Tools | View VirtualRadarLog.txt) does it have an exception in there from around the time that you ran the report? If so, what was the exception?

Posts: 17
Joined: Mon Jun 02, 2014 4:06 pm

Re: Bugs in 2.2.0

Post by TurboCommander » Thu Oct 29, 2015 10:19 pm

I just upgraded from to and get an error on launching it. All was well before the update. Here is the entry from the log, any ideas?

[2015-10-29 22:13:29.493 UTC] [t3] Program started, version, build date 9/7/2015 12:18:23 AM UTC
[2015-10-29 22:13:29.493 UTC] [t3] Working folder C:\Users\User\AppData\Local\VirtualRadar
[2015-10-29 22:13:30.165 UTC] [t3] Caught exception when starting Database Writer: System.MissingMethodException: Method not found: 'VirtualRadar.Interface.Listener.IFeed VirtualRadar.Interface.Listener.IFeedManager.GetByUniqueId(Int32)'.
at VirtualRadar.Plugin.BaseStationDatabaseWriter.Plugin.StartSession()
at VirtualRadar.Plugin.BaseStationDatabaseWriter.Plugin.Startup(PluginStartupParameters parameters)
at VirtualRadar.Library.Presenter.SplashPresenter.StartPlugins(IWebSite webSite)

Posts: 365
Joined: Sat Feb 09, 2013 12:15 pm
Location: Wick St Lawrence

Re: Bugs in 2.2.0

Post by jonfear » Sat Oct 31, 2015 8:56 am

Did you upgrade all the packages you have installed? The fault appears to point to the database writer. If you upgrade the main program, you need to update the plugins as well...


http://www.360radar.co.uk, the new name for MLAT Radar in the UK and Western Europe.

Former PP feeder Bm. No longer feeding. I do not have time to sort out imaginary problems with NTP
when it has been working fine for 2+ Years.

Posts: 17
Joined: Mon Jun 02, 2014 4:06 pm

Re: Bugs in 2.2.0

Post by TurboCommander » Wed Nov 04, 2015 4:31 pm

That was it, thank you! I forgot to update the database writer plugin. I was about to revert to the previous program version but tried the updated plugin first and it worked great.