Site root folder

Are you having problems with using or developing a plugin? Let me know here.
Post Reply
mouflonwrangler
Posts: 9
Joined: Mon Dec 03, 2018 4:02 pm

Site root folder

Post by mouflonwrangler » Sat Jul 04, 2020 8:12 am

Hi,
I have my CustomContent working OK in displaying my own aircraft markers.

My "Site root folder is set to

C:\VRS Data\CustomContent\Web\

and the scripts for displaying the new aircraft markers is

C:\VRS Data\CustomContent\Web\Scripts

and the markers, the path is

C:\VRS Data\CustomContent\Web\images\markers

I am tryig to utilise the script and data file of Thierry Leconte for displaying waypoints.

However in his instructions for incorporating this, he uses the Site root folder of

F:\VRS\images

and the scripts in

F:\VRS

Moving the scripts and markers into my file and directory structure is not an issue but the "Site root folder" seems to be an issue as within the script that works out which image/marker to use is.

I am fairly certain that it has something to do with the "icon" statement in the "wptoption" within the code, as per below.

{
wptoption =

{
clickable: true,
draggable: false,
editable: false,
icon:
{
url: waypoints.type + ".png",
},

visible: true,
tooltip: waypoints.info,
position:

{
lat: waypoints.lat,
lng: waypoints.lng
}
}


if(waypoints.type == "ndb" || waypoints.type == "ndbdme" )

{
wptoption.icon.size={ width:34,heigth:34};
wptoption.icon.anchor={ x:16,y:16};
}

else

{
wptoption.icon.size={ width:16,heigth:16};
wptoption.icon.anchor={ x:8,y:8};
}

marker = _Map.addMarker(waypoints.type + "-" + waypoints.id, wptoption);
}

Could anyone assist in making this work, please.

Regards
Barry.

Post Reply