Page 1 of 1

Web Server installed but cannot create user

Posted: Wed Aug 17, 2016 7:56 pm
by TurboCommander
I updated to 2.4. installed the web server plugin and see instructions to set a user as Admin and go to users and create a user if I don't have one. Ok, in the Web Server, Users screen, how do I create a user??? I don't see any plus or add buttons or any way to indicate how to add a user.

Re: Web Server installed but cannot create user

Posted: Wed Aug 17, 2016 8:05 pm
by TurboCommander
Nevermind, I still don't know how to do it in the GUI but I used the commands shown on the website in the web server download area and that worked

Via the Command Line

Start the server in headless mode and pass two switches to create and/or configure a user as an administrator:

Mono users: mono VirtualRadar.exe -nogui -createAdmin:name -password:password
Windows users: VirtualRadar.exe -nogui -createAdmin:name -password:password

Note that there is no space after the colon in -createAdmin and -password.

Once an administrator user has been created you can start the server in headless mode using the -nogui switch.

Re: Web Server installed but cannot create user

Posted: Tue Aug 23, 2016 12:55 am
by agw
I can see how it's a bit confusing - the web server "Users" sub-menu is talking about users that can authenticate with the web site.

To create users in the GUI you go to the Users section (Tools | Options | Users - not Tools | Options | Web Server | Users) and create / delete / modify them there.