Preview build 34526 throws an exception

Bug reports and questions about running Virtual Radar Server on Linux
Martin
Posts: 23
Joined: Wed Jan 14, 2015 9:04 pm
Location: Churchdown, Gloucester

Preview build 34526 throws an exception

Postby Martin » Sun Jan 08, 2017 9:47 am

I want to try the latest preview (2nd Jan 2017). I downloaded it and unpacked it. It starts fine but throws an exception when I browse to either the main site or admin site.

[2017-01-08 08:30:35.806 UTC] [t1] Program started, version 2.4.0.34526, build date 02/01/2017 19:10:52 UTC
[2017-01-08 08:30:35.809 UTC] [t1] Working folder /home/pi/.local/share/VirtualRadar
[2017-01-08 08:30:45.504 UTC] [t17] System.TypeLoadException: Could not load type 'System.Security.Claims.ClaimsIdentity' from assembly 'VirtualRadar.WebServer'.
at VirtualRadar.WebServer.WebServer+DefaultProvider.EndGetContext (IAsyncResult asyncResult) [0x00000] in <filename unknown>:0
at VirtualRadar.WebServer.WebServer.GetContextHandler (IAsyncResult asyncResult) [0x00000] in <filename unknown>:0

I have reverted to build 30532 which works fine.

agw
Posts: 1791
Joined: Fri Feb 17, 2012 3:20 am

Re: Preview build 34526 throws an exception

Postby agw » Sat Jan 14, 2017 2:47 pm

Up until now VRS ran under .NET 3.5. I've changed that for the next release, from now on VRS will need at least .NET 4.6.1 or Mono 4.4.

In your case you're running under Mono and the exception is getting thrown because you have a version older than 4.4 installed. If you bring your Mono installation up to date then you should be able to run the preview VRS.

Martin
Posts: 23
Joined: Wed Jan 14, 2015 9:04 pm
Location: Churchdown, Gloucester

Re: Preview build 34526 throws an exception

Postby Martin » Sun Jan 15, 2017 1:52 pm

If you bring your Mono installation up to date


Oh dear and I had been doing so well up until now. The Raspbian repository seems to offer me Mono 3.2.8 and I cannot see how to get Mono 4.4. As is generally the case when I stray into the Linux world, Googling has managed to confuse me further. Do I have to compile Mono or is there a package that I can apt-get? If I have to compile, then the latest is mono 4.8.0.429, should I be trying to build this?

Sorry, I am a complete numpty when it comes to Linux.

andrew
Posts: 16
Joined: Sat Apr 26, 2014 10:31 am

Re: Preview build 34526 throws an exception

Postby andrew » Sun Jan 15, 2017 9:01 pm

I had a similiar error, just see my post: viewtopic.php?f=11&t=1225#p6122

Martin
Posts: 23
Joined: Wed Jan 14, 2015 9:04 pm
Location: Churchdown, Gloucester

Re: Preview build 34526 throws an exception

Postby Martin » Mon Jan 16, 2017 11:05 am

Andrew,

Thanks for the pointer. I followed the update procedure you highlighted and mono is now version 4.6.2.16. Preview VRS is running just fine on my RPi3.

Cheers,
Martin


Return to “VRS on Linux”

Who is online

Users browsing this forum: No registered users and 1 guest