Unable to save settings with WebAdmin

Bug reports and questions about running Virtual Radar Server on Linux
Post Reply
Posts: 1
Joined: Wed Oct 05, 2016 8:54 pm

Unable to save settings with WebAdmin

Post by pe2kmv » Wed Oct 05, 2016 9:09 pm

Hi everyone,

As I'm rather new in the ADS-B business and especially a newbie regarding VRS, I hope to find some answers here.

Today I managed to get VRS running under mono on my Debian server. As the server is headless somewhere in a storage room, I'm running VRS with the '-nogui' option and with the WebAdmin plugin in place.

When calling the WebAdmin URL I can login and see all settings, but none of these settings are stored. Even when I click 'save' without having anything changed, I get a green message box telling me to correct all errors and try again. But what errors? Everything seems to be alright. So as I wasn't able to change the settings for the receiver, I went into the XML file and changed the IP address so the VRS server can connect to the RPi running dump1090. After saving and restarting VRS the connection is established and I see flight data at the right hand side of the screen on the client computer. But the map section remains completely empty (no planes AND no map...).

I've tried different machines, with the same result (except on Safari: things went worse). I've also installed the Win version on my old WinXP notebook, which runs really well. But I don't want to have a Windows computer running all day cranking up my energy bill.

Server: Debian 7 on an aging Pentium III
Client 1: WinXP + Chrome
Client 2: OSX 10.9.5 + Safari + FireFox + Chrome

What's going on here...? What am I overlooking? Any help is really appreciated!


Posts: 2249
Joined: Fri Feb 17, 2012 3:20 am

Re: Unable to save settings with WebAdmin

Post by agw » Tue Oct 18, 2016 10:23 pm

Sorry for the delay in replying. The errors should be shown against the fields that the validation is having a problem with, you get no-entry icon against the field. Each section that contains an error should also be showing a no-entry icon in its header.

You can see an example of this by adding a merged feed and then not assigning any receivers to it. When you click save the Merged Feeds header has a no-entry icon against it and then in the list of merged feeds you get a no-entry icon against the one with the problem. When you go into the merged feed it should have the validation message there, in this case "Please supply at least 2 receivers to merge".

However you're not the first one to report problems with the visibility of the validation messages. I'll add a roll-up of the messages somewhere near the save button.

If there's no map showing then that's unlikely to be anything to do with settings, it sounds more like a JavaScript problem. Do you have any error messages in the JavaScript console window (press F12 after loading the page, there should be a console tab somewhere in there that shows error messages)?

Post Reply