Page 1 of 1

(Preview) WebAdmin doesn't work properly

Posted: Thu Aug 10, 2017 7:44 pm
by Datamix
Hey

Somehow the Web Admin Plugin on my system doesn't work.
I get some JS errors in the developer console
see screenshot

Image



Specs:
Preview VRS (17-FEB-2017)
Preview Web Admin Plugin (02-JAN-2017)
Dump1090-mutability
Raspberry PI 2
Firefox v54 / Chrome v60


Btw. Thanks for developing VRS, really appreciated.

Re: (Preview) WebAdmin doesn't work properly

Posted: Fri Aug 11, 2017 9:28 am
by Datamix
Info:
I tried the current (stable) 2.4 version with the current web admin pluign but I get the same result (even with diffrent OS, Browser and Hardware).

Re: (Preview) WebAdmin doesn't work properly

Posted: Sun Aug 20, 2017 9:22 pm
by agw
It looks like there's an unterminated string in the German translation of the web admin strings file. What happens if you uninstall the language pack, do you still get the problem?

Re: (Preview) WebAdmin doesn't work properly

Posted: Mon Aug 21, 2017 9:25 am
by Datamix
The problem is my region. Im based in Switzerland and the OS language is German. But we (Switzerland and Germany) have regional differences. Thats why there are severals "Locale" in the OS --> de_CH or de_DE

On big difference is how we group numbers (which symbol we use) (German: "Symbol für Zifferngruppierung" on the screenshot). The Germans use a " . " (dot) but the Swiss use a " ' " (apostrophe).




This causes the error because the apostrophe is not escaped.
/VirtualRadar/Web/script/globalize.js

Code: Select all

Globalize = {
        culture: function() {
            return {
                numberFormat: {
                    name: 'de-CH',
                    groupSizes: [3],
----->             ',': ''',
                    '.': '.',
                    pattern: ['-n']
WORKAROUND: change locale from de_CH to de_DE

Raspian: sudo raspi-config --> change locale

Or Windows --> Control Panel --> Region

Locale: German, Germany
Image

Image



Locale: German, Switzerland
Image

Image