Feed filter plugin

Bug reports and questions about running Virtual Radar Server on Linux
MattBNA
Posts: 9
Joined: Sat Mar 11, 2017 8:32 am

Re: Feed filter plugin

Post by MattBNA » Fri Jun 29, 2018 9:17 pm

agw wrote:
Fri Jun 29, 2018 8:22 pm
Yes, it'll be because you have never run the Options screen for the plugin. If you don't have a GUI then you have no way of running the options screen.
Ok, so that being the case, I'm assuming that I'm not crazy and no one has ever been able to get FeedFilter running on a headless remote server then, yes?

Thanks for your timely help with this issue, Sir. :)

Matt

--

spotterssol
Posts: 5
Joined: Fri Sep 22, 2017 11:27 am

Re: Feed filter plugin

Post by spotterssol » Sat Jun 30, 2018 12:00 pm

MattBNA wrote:
Thu Jun 28, 2018 11:11 am
agw wrote:
Wed Jun 27, 2018 11:39 am
In version 3 you don't need the page part, although it doesn't hurt if you supply it. http://127.0.0.1/VirtualRadar/FeedFilter will work.

Is VRS showing any warnings about plugins not loading?
No complaints in the log whatsoever.

I'm running under Mono on a remote server, so the localhost address obviously doesn't do me any good from here - but even attempting to load the plugin while connected to my server over the VPN (which gives me an internal address on that side) still doesn't work. Same thing - 404. I've been accessing the WebAdmin plugin for years from home or my phone by connecting to the VPN on the server without any issues whatsoever. FeedFilter, on the other hand, isn't having it.

Just for the heck of it, I attempted to load it locally on the server using the old CLI browser Lynx... Attempting http://127.0.0.1:37200/VirtualRadar/FeedFilter (with and without /Index.html - not that it matters either way) actually gets me a login prompt...but once I supply the proper admin credentials it still throws a 404. Makes no sense as I can see the Index.html file in the ~/VRS/Plugins/FeedFilter/Web/FeedFilter folder.

Thanks again,
Matt

--
+1, same steps, can't get it working.

agw
Posts: 2105
Joined: Fri Feb 17, 2012 3:20 am

Re: Feed filter plugin

Post by agw » Sat Jun 30, 2018 11:30 pm

There's a new version 3 preview of the feed filter plugin up on the site with web admin support.

If you're not using the web admin plugin then just go into the plugin options and enable the plugin. You'll then be able to see the page.

MattBNA
Posts: 9
Joined: Sat Mar 11, 2017 8:32 am

Re: Feed filter plugin

Post by MattBNA » Sun Jul 01, 2018 4:49 pm

agw wrote:
Sat Jun 30, 2018 11:30 pm
There's a new version 3 preview of the feed filter plugin up on the site with web admin support.

If you're not using the web admin plugin then just go into the plugin options and enable the plugin. You'll then be able to see the page.
Just installed it real quick and it is now showing in Web Admin... Unfortunately, I can only access it through the text-only Lynx browser via the localhost address of the server (which is basically useless for these purposes).

I've configured the access settings (IP ranges) for FeedFilter to match those of Web Admin and the Database Editor (which I've never had any issues with) and even set it on 'Unrestricted' as a test, but still receive a 404 error when trying to access the FeedFilter URL from my home computer or phone (both of which are in allowed IP ranges, not that it should matter in Unrestricted mode).

Thoughts?


Thanks,
Matt

--

MattBNA
Posts: 9
Joined: Sat Mar 11, 2017 8:32 am

Re: Feed filter plugin

Post by MattBNA » Thu Jul 05, 2018 3:56 am

MattBNA wrote:
Sun Jul 01, 2018 4:49 pm

I've configured the access settings (IP ranges) for FeedFilter to match those of Web Admin and the Database Editor (which I've never had any issues with) and even set it on 'Unrestricted' as a test, but still receive a 404 error when trying to access the FeedFilter URL from my home computer or phone (both of which are in allowed IP ranges, not that it should matter in Unrestricted mode).
No idea why, but I tried to access it again just now after not messing with it for a few days...and it decided to work all of the sudden. <shrug>

Thanks for getting this cleaned up for us, agw!

Matt

--

spotterssol
Posts: 5
Joined: Fri Sep 22, 2017 11:27 am

Re: Feed filter plugin

Post by spotterssol » Wed Jul 11, 2018 1:12 am

MattBNA wrote:
Thu Jul 05, 2018 3:56 am
MattBNA wrote:
Sun Jul 01, 2018 4:49 pm

I've configured the access settings (IP ranges) for FeedFilter to match those of Web Admin and the Database Editor (which I've never had any issues with) and even set it on 'Unrestricted' as a test, but still receive a 404 error when trying to access the FeedFilter URL from my home computer or phone (both of which are in allowed IP ranges, not that it should matter in Unrestricted mode).
No idea why, but I tried to access it again just now after not messing with it for a few days...and it decided to work all of the sudden. <shrug>

Thanks for getting this cleaned up for us, agw!

Matt

--
To get it working you need to:
-install the plugin;
-restart server;
-enable the plugin in "vrs web admin";
-restart server again.

Post Reply