Web Site - Initial Settings

Bug reports and questions about running Virtual Radar Server on Linux
Post Reply
geffers
Posts: 14
Joined: Fri Jun 29, 2018 4:58 pm

Web Site - Initial Settings

Post by geffers » Sun Jul 22, 2018 5:31 pm

Folks,

Got v2.4.2 working fine on my Linux Ubuntu system with one problem.

Under options, web site, initial settings clicking on the http://127.0.0.1:8080/VirtualRadar/desktop.html or the mobile and settings option gets no response. If I enter that address directly into a browser then the page comes up fine.

127.0.0.1 is set correctly in the hosts file.

This worked fine when I did similar in Windows10 but not joy in Linux.

I am getting the impression it is a filepath problem so am asking; does the VRS folder have to be in a specific Linux directory? I have no mono issues so am assuming it is not associated with that location.

Geffers

agw
Posts: 2105
Joined: Fri Feb 17, 2012 3:20 am

Re: Web Site - Initial Settings

Post by agw » Mon Jul 23, 2018 9:19 pm

You could just copy the settings across from your Windows machine, or if you can open the folder manually then that'll be fine. You don't have to use the links in the options screen to start

The failure to start the browser will be a Linux configuration issue, as far as I'm aware when I tell mono that I want to start a URL mono just asks Linux to fire up the default browser and go to that URL. I've just tried those links on Ubuntu 18.04 and they work fine.

It will not be a file path issue, VRS does not need to be in a specific directory.

geffers
Posts: 14
Joined: Fri Jun 29, 2018 4:58 pm

Re: Web Site - Initial Settings

Post by geffers » Wed Jul 25, 2018 2:53 pm

Thank you for reply.

Windows and Linux on same machine, dual boot, so copying can be awkward though Linux can read Windows file system. Will look in to that one.

I've used Linux for years and not had a problem with it opening a local filepath but seldom an issue so not something I can recall having to address.

Geoff

WiganPI
Posts: 2
Joined: Sun Mar 11, 2018 9:31 am
Contact:

Re: Web Site - Initial Settings

Post by WiganPI » Mon Aug 27, 2018 2:18 pm

geffers wrote:
Wed Jul 25, 2018 2:53 pm
Thank you for reply.

Windows and Linux on same machine, dual boot, so copying can be awkward though Linux can read Windows file system. Will look in to that one.

I've used Linux for years and not had a problem with it opening a local filepath but seldom an issue so not something I can recall having to address.

Geoff
maybe save to a usb stick and trandfer acroos that way?
Click Here For My VRS Install
360 Radar Contributor | ADSB Receiver Project Contributor | Opensky Network Contributor | ADSBhub Contributor

Post Reply