Page 1 of 1

Missing plane icons / markers

Posted: Sat Oct 19, 2019 6:14 am
by peteclyde
Hey all,

I''m running VRS on a Centos machine. In the last week or so I've lost my plane markers. I've uninstalled / reinstalled to no avail. Call signs etc are showing, plus if I select an aircraft I can see it's route line, but no markers.



Any ideas?

Thx,

Pete

Re: Missing plane icons / markers

Posted: Wed Oct 23, 2019 10:21 am
by ssuttner
Same Problem with Raspbian GNU/Linux 9 (stretch), Mono 6.4.0.198 (tarball Tue Sep 24 01:57:00 UTC 2019) and also the newest Version 2 Preview [2019-10-12 21:12:59 UTC] VirtualRadar.tar.gz Mono GZIP tarball.
Maybe a Mono issue?
see: https://mostlecapi.de/vr

Update:
With Chrome and also Edge Browser on Windows 10: Silhouettes visible, Flags visible, Marker not visible
With Chrome Browser on Android Smartphone: Silhouettes not visible, Flags not visible, Marker not visible
On mobile page the button to reach the List is not visible with Windows and Android

Re: Missing plane icons / markers

Posted: Sun Oct 27, 2019 6:34 pm
by mgunther
I'm having the same issue and I also suspect that a recent Mono update might have introduced it. That was the only change I'm aware of.

I have:

Code: Select all

$ lsb_release -a
No LSB modules are available.
Distributor ID: Ubuntu
Description:    Ubuntu 18.04.3 LTS
Release:        18.04
Codename:       bionic
And:

Code: Select all

$ mono -V
Mono JIT compiler version 6.4.0.198 (tarball Tue Sep 24 01:21:28 UTC 2019)
Copyright (C) 2002-2014 Novell, Inc, Xamarin Inc and Contributors. www.mono-project.com
        TLS:           __thread
        SIGSEGV:       altstack
        Notifications: epoll
        Architecture:  amd64
        Disabled:      none
        Misc:          softdebug
        Interpreter:   yes
        LLVM:          yes(610)
        Suspend:       hybrid
        GC:            sgen (concurrent by default)
I might try to revert to previous Mono version and will post an update if successful.

Re: Missing plane icons / markers

Posted: Sun Oct 27, 2019 7:02 pm
by mgunther
UPDATE:
Reverting to Mono version 6.0.0.334 solves the issue of missing icons and markers. These pages helped me to revert the version:
https://www.mono-project.com/docs/getti ... r-releases
https://stackoverflow.com/questions/337 ... on-of-mono

On my system, these are the steps I took but paths and files will vary for different OS's.

Steps for Ubuntu 18.04.3 LTS "bionic"

1) Stop VRS

2) Edit /etc/apt/sources.list.d/mono-official-stable.list to read:

Code: Select all

# commented because current Mono 6.4.0.198 breaks VRS markers and icons, 27th Oct 2019
# deb https://download.mono-project.com/repo/ubuntu stable-bionic main

# pin to most recent pre-6.4 version instead
deb https://download.mono-project.com/repo/ubuntu bionic/snapshots/6.0.0.334 main
3) Remove and re-install Mono

Code: Select all

sudo apt-get remove mono-complete
sudo apt-get update
sudo apt autoremove
sudo apt-get install mono-complete
4) Check Mono version is now 6.0.0.334:

Code: Select all

$ mono -V
Mono JIT compiler version 6.0.0.334 (tarball Thu Sep 12 21:34:14 UTC 2019)
Copyright (C) 2002-2014 Novell, Inc, Xamarin Inc and Contributors. www.mono-project.com
        TLS:           __thread
        SIGSEGV:       altstack
        Notifications: epoll
        Architecture:  amd64
        Disabled:      none
        Misc:          softdebug
        Interpreter:   yes
        LLVM:          yes(600)
        Suspend:       hybrid
        GC:            sgen (concurrent by default)
5) Start VRS and enjoy markers, icons, flags and silhouettes again:)