RasPI Mono reverted to older version

Bug reports and questions about running Virtual Radar Server on Linux
Post Reply
Posts: 11
Joined: Sat Sep 06, 2014 7:18 pm
Location: nr Pole Hill VOR-DME (Todmorden,UK)

RasPI Mono reverted to older version

Post by Bro » Wed Dec 17, 2014 4:09 pm

I run VirtualRadar and dump1090 on the same device and had 2.0.1 running fine

I have reverted back to 2.0.1 on my Raspberry Pi (w/Mono) as I have encountered some problems with the newer versions (including the latest mono tweaked beta from agw)

These were:
higher cpu usage (full with new versions midway with older)
the database writer plugin stopped working a few hours in on the newer versions (2.1.0 and beta)
dump1090 kept stopping without producing an error.. then today it kept failing to run and spewed out usb related(i think) errors, spent this morning trying to suss it out but got nowhere until I reverted to 2.0.1
VR would occasionally stop working and get closed by mono.

I got/still get the odd exception pop up in either the mono console or as a pop up... non of them have stopped the program from functioning.

Posts: 2248
Joined: Fri Feb 17, 2012 3:20 am

Re: RasPI Mono reverted to older version

Post by agw » Thu Dec 18, 2014 12:47 am

I wouldn't be too surprised if something in the networking code is more CPU intensive in the new version than in the old version. It's going to be painful to profile the program on the Pi. I've profiled it on the PC but that's not really comparing like-for-like, it's very likely that whatever's going slow on the Pi may not show up as a problem on Windows and a beefy i7.

I'll have a read up on mono's profiling tools over Christmas and see if they can be made to run on the Pi. If I can get it profiled then I should be able to see pretty quickly what's causing it to hog the CPU.

Post Reply