No planes on mobile map

Bug reports and questions about running Virtual Radar Server on Linux
Post Reply
zivan56
Posts: 2
Joined: Wed Feb 13, 2013 3:18 am

No planes on mobile map

Post by zivan56 » Wed Feb 13, 2013 3:30 am

Hi,

First of all, great program...thanks for making it! :)

I noticed this error on the latest version running on Linux (1.2.0.39247). When visiting the iPhoneMap.htm, there are no plane icons. Upon looking at the Javascript error console, I see:
"MarkerWithLabel is not defined "
Which might be why there are no airplane markers on the map. I only use this map, so its a bit annoying to use....the Windows version and the regular GoogleMap.htm work fine. Tried multiple browsers and none worked.

Also, File-> Statistics seems to crash the program. Running on Ubuntu 12.10 x86-64.

Thanks,
Ivan

agw
Posts: 2241
Joined: Fri Feb 17, 2012 3:20 am

Re: No planes on mobile map

Post by agw » Wed Feb 13, 2013 9:38 am

Agh! Yes, that's a bug, sorry about that. It'll be fixed in the next release, which I'm hoping will be this weekend. I'd roll back to the previous version (http://www.virtualradarserver.co.uk/VersionHistory.aspx) until then.

I haven't tried VRS under 12.10, the whole Amazon search thing kind of put me off it :), but I'll install it on a VM and see if I can reproduce the crash.

zivan56
Posts: 2
Joined: Wed Feb 13, 2013 3:18 am

Re: No planes on mobile map

Post by zivan56 » Thu Feb 14, 2013 3:21 am

Ok thanks, I will use the older version for now.

Yeah, Ubuntu is slowly becoming more commercially oriented, but I can't really find anything as good to be honest in terms of stability/just working.

About the Statistics bug, I don't believe it will be easily reproducible or may not even be your programs fault. I tried to get it to do this again for a stack trace and couldn't. However, I found if you go to Tools -> Settings and click OK and then go to File -> Statistics, the main window will become "modal" and you can't close the stats windows until you exit the program. Also, if you click reset, you sometimes get an error about "ArgumentOutOfRangeException." All the namespaces are in System.Windows.* in the stack trace, so it's probably a Mono bug. Also got a "Object reference not set to an instance of an object" error as well just by opening it, the whole trace from VirtualRadar.Program.StartApplication were System.Windows.Forms.*
I don't believe they ever really got the Windows forms working properly in Linux, so probably not much can be done about that. I don't really use the dialog except once in a blue moon so its not a big deal, but they may all be related.

Mono version is 2.10.8.1 (just did a apt-get install mono-complete in Ubuntu).

agw
Posts: 2241
Joined: Fri Feb 17, 2012 3:20 am

Re: No planes on mobile map

Post by agw » Thu Feb 14, 2013 10:23 am

I've found and fixed the statistics bug - I'm surprised it worked on Windows to be honest, I was updating the display from a background thread which is usually a pretty good way to crash a .NET program. I've tried the two scenarios you've described and it's not doing either after the fix so it looks like those were caused by the background update as well. Certainly the reset counters problem sounds like the kind of thing you would expect, it triggers a reset and refresh of the counters on the GUI thread and if the background thread happened to be refreshing them at the same time then chaos would ensue. You'd have to get the timing right to see it though.

Post Reply