Page 1 of 1

Dump1090 on Rpi2 not feeding into VRS

Posted: Wed Feb 10, 2016 4:21 am
by gregw916
I've looked over every question the in forum here, and still can't get the output from dump1090 into VRS. I run dump 1090 with no command line switches, and set up the receiver as "basestation" using port 30003. When I test the connection, it says one can't be made. I look at the VRS main screen and never see any messages coming in.

I'm also not running VRS with any command line switches just "mono VirtualRadar.exe" from LXterm.

Mind you I'm doing this in the web interface into VRS for the options. Since we know that VRS will crash when going into the options, this is a preview edition I was told to try out.

Dump1090 is running and is displaying output, so I know it's working right. I've tried all the other ports, 30001 thru 30005, and no change. I've also tried using AVR/Beast mode. Nothing doing there either.

Any suggestions?

Re: Dump1090 on Rpi2 not feeding into VRS

Posted: Thu Feb 11, 2016 3:17 am
by gregw916
Never mind. I figured it out.

I wasn't using the right command switch when running dump 1090. I didn't realize it needed the command to send data to the network for VRS to pick it up.

I'm using "BaseStation" for the receiver feed over the default port of 30003.

The proper command line for dump 1090 for me is : "./dump1090 --net --net-http-port 8085 --gain -10 --ppm 56". This puts the decoding signal on the local pc, and sets the port for the Dump 1090 web interface at on the local pc, sets the gain of the SDR to auto, and uses 56 for my ppm correction for the signal. Because VRS wants to use the port :8080 for it's page, and the web based settings page. They both can't be on :8080.