Page 1 of 1

Problem with Configuration file

Posted: Wed Feb 24, 2016 7:45 am
by jimjack
Hi,

I used VRS many time ago on Linux without any problems. Last version was 2.3.1.
But last weekend it stopped working and I can't start VRS again. Unfortunately it makes no error message on startup.

Now I changed the configuration file and configure the settings new. All work well but on VRS startup it say the configuration file is corrupt.
I think there are problems with the receiver location. I set it with "," here in Germany. These settings works well in the last.
When I set it with "." the programm changed ist to unusable values.

Are there any problem with this settiong - "," / "." - the receiver location?

With best regards,
jimjack

Re: Problem with Configuration file

Posted: Sun Feb 28, 2016 1:39 am
by agw
The numbers need to be entered with decimal points in the XML file. However the user interface should let you enter them with whatever your current locale settings support. If your locale is Germany then you will need to enter them with commas and decimal points should be rejected.

However, that's under Windows. I'm not sure how Mono deals with locale settings. But either way, it should be decimal points in the XML. If VRS is writing decimal numbers with commas to the XML file then let me know.

Re: Problem with Configuration file

Posted: Mon Feb 29, 2016 7:23 am
by jimjack
I've tested the configuration file - Receiver location - with "." and "," but I get the same error on VRS statup.

Image

I don't know wich setting is false.

I've erased the configuration and set all new but the error comes again. And I've problems with the Receiver location setting when I set this
in the VRS directly.

Image

This error occurs when I set the location with ",".

Image

This error comes when I open the Option settings again.
I've set "51,006" and "13,764" and VRS corrects the setting as you see.


When I set the location with "." VRS corrects to a setting with "," but this is for instance from "51.000" to "89,000".


Strangely, the settings have worked so far for VRS the last time. I've had an configuration and don't change any setting.

Re: Problem with Configuration file

Posted: Thu Mar 24, 2016 12:55 pm
by jimjack
Hi agw,

are there new insights on my problem?

Sorry, but my VRS don't run anymore...

Re: Problem with Configuration file

Posted: Sun Mar 27, 2016 3:16 pm
by agw
If you email me your configuration file I'll take a look (the email address is on the web site). Regarding editing the file once it's been fixed, I think it wouldn't hurt to avoid relying on Mono's WinForms implementation - you could try installing the latest preview version of VRS from http://www.virtualradarserver.co.uk/Preview.aspx and installing the web admin plugin along with it. Create an admin user in VRS using the instructions here:

http://forum.virtualradarserver.co.uk/v ... f=11&t=970

and then editing the configuration from the browser. I'm not sure how the web admin plugin behaves with localised values at the moment, but whatever it's doing it should be consistent :)