Page 1 of 1

Strange problem

Posted: Tue Jan 13, 2015 9:52 pm
by airbus340
I have got a strange problem the last couple of days... VRS worked great for over a week and suddenly this problem started, after no updates or changes.

When I leave VRS everything is working normal and when I check back later then the planes on the map are moving around as they should and the aircraft list work as it should, but VRS dont report my flights to the daily log or write new ones in the SQB file anymore... After restarting VRS it work normal agan, sometimes 2 hours and sometimes 15 hours before it freeze the reports.

Any ideas?

Cheers
John

Re: Strange problem

Posted: Thu Jan 15, 2015 1:18 am
by agw
There has been a problem reported elsewhere with the BaseStation.sqb file getting locked such that the database writer can't update it any more. If that's what's happening here then you should see exceptions from SQLite in the log file (Tools | View VirtualRadarLog.txt) that talk about the database file being locked.

Re: Strange problem

Posted: Thu Jan 15, 2015 8:55 am
by airbus340
Thank you very much for your reply!

You were right, here is what it say: [2015-01-13 19:37:21.014 UTC] [t3] Database writer plugin caught exception on flushing old flights: System.Data.SQLite.SQLiteException: database is locked
database is locked

So is there any solution to fix this? Or maybe the old version is to be found somewhere?
I used the old version for years, to my hard drive crashed, and there were never any problems with that version. After the HD crash the new version was published and the problems started.

Re: Strange problem

Posted: Sun Jan 18, 2015 4:02 pm
by agw
Yes, there's definitely something a bit screwy going on there, you're the second person to report it. The tricky bit is that so far I've yet to reproduce it.

Do you have anything else writing to the BaseStation.sqb file, anything populating the aircraft records?

All (or almost all) of the different versions of VRS can be downloaded from the site: http://www.virtualradarserver.co.uk/VersionHistory.aspx. You should be able to just install 2.0.2 over the top of 2.1, but you'll also need to reinstall old versions of any plugins that you have. The plugin installers should also be on that page.

Re: Strange problem

Posted: Sun Jan 18, 2015 9:16 pm
by airbus340
Thank you very much for your help!

Great news that the older versions is to be found on the site as this is by far the best software for radar!

I have nothing else writing to the BaseStation.sqb and nothing is populating what it writes, I do it manually every evening before I restart VRS. So I am not much of help, unfornately.

The only thing I can think of is that I have BaseStation software installed, but I have never used it same time as VRS, and they have separate sqb-files with different names, so not writing to eachother.