Database Editor Plugin - Authentication Question

Discussions about the preview versions of Virtual Radar Server.
Forum rules
Please bear in mind if you do install a preview version that it is unfinished code, there may be bugs, bits missing, things that don't work etc.

Posts in this forum will not show up in forum search results. Old threads will be pruned occasionally.
Post Reply
Me109
Posts: 37
Joined: Sat Nov 01, 2014 4:54 pm
Location: KORH

Database Editor Plugin - Authentication Question

Post by Me109 » Thu Nov 05, 2015 1:32 pm

On 2 different VRS instances, both are the latest preview version, I have the Database Editor plugin installed/enabled. Both sites require user authentication, and both are setup as unrestricted for the plugin (I think unrestricted is simply in terms of IP though and not user?).

In the one instance only the user "admin" is permitted to access the editor page out of a pool of 20-30 users, the other instance has only a single user. I can't see where in the options this may be set and why the behavior is different.

I do like the idea of only an admin having access to making edits, I'm just trying to understand why it is behaving that way :)

agw
Posts: 2241
Joined: Fri Feb 17, 2012 3:20 am

Re: Database Editor Plugin - Authentication Question

Post by agw » Thu Nov 05, 2015 10:12 pm

The database editor will only let users that are flagged as administrators (Tools | Options | Web Server | Administrators) access the page. You're right in thinking that the restrictions in the plugin options screen are just for the IP address. In an earlier preview I also had a flag to let you say that you didn't need to be authenticated to access the page, the idea being that you could set up IP address restrictions to only allow LAN addresses to access the page and then turn authentication off, but then I decided that was going to be a recipe for disaster and got rid of it :)

Me109
Posts: 37
Joined: Sat Nov 01, 2014 4:54 pm
Location: KORH

Re: Database Editor Plugin - Authentication Question

Post by Me109 » Fri Nov 06, 2015 12:51 am

Thanks Andrew, I see it now.

Post Reply