VRS V1.2.1

Bug reports and questions about running Virtual Radar Server on Linux
jimjack
Posts: 12
Joined: Mon Feb 04, 2013 1:10 pm

VRS V1.2.1

Post by jimjack » Mon Mar 04, 2013 7:20 am

Hi,

thanks for the new version V1.2.1.

At the first, this version runs very smooth on my Linux server and at the moment without a bug. ;-).

Regards
Steffen
Last edited by jimjack on Tue Mar 05, 2013 8:04 am, edited 1 time in total.

agw
Posts: 2241
Joined: Fri Feb 17, 2012 3:20 am

Re: VRS V1.2.1

Post by agw » Mon Mar 04, 2013 11:44 am

Glad to hear it :D

aalested
Posts: 14
Joined: Fri Feb 22, 2013 10:48 am

Re: VRS V1.2.1

Post by aalested » Tue Mar 05, 2013 6:32 pm

jimjack

What OS are you running ?

Erik

jimjack
Posts: 12
Joined: Mon Feb 04, 2013 1:10 pm

Re: VRS V1.2.1

Post by jimjack » Wed Mar 06, 2013 7:49 am

@Erik,

thats an Debian-Linux 6 on an Intel atom D525.

Mono installation was without any problems.
VRS runs also without any problems.

Regards,
Steffen

aalested
Posts: 14
Joined: Fri Feb 22, 2013 10:48 am

Re: VRS V1.2.1

Post by aalested » Wed Mar 06, 2013 8:03 pm

@jimjack

Many thanks for your reply to me.

Ok with Debian.

Could I ask you to tell me about how you did the install ?.

Included your set up of your router for NAT/Forwarding ?.

I have issues setting this up here, and at the moment I look at awfull Google-Earth :_)

Eventuall to save bandwith direct.

I'm on eja@urbakken.dk

/Erik

jimjack
Posts: 12
Joined: Mon Feb 04, 2013 1:10 pm

Re: VRS V1.2.1

Post by jimjack » Thu Mar 07, 2013 11:39 am

Hi Erik,

yes I can help you. No problem.


1. Installation VRS:

I've decompressed the files for Linux in one directory

http://www.virtualradarserver.co.uk/Fil ... dar.tar.gz
http://www.virtualradarserver.co.uk/Fil ... ack.tar.gz
http://www.virtualradarserver.co.uk/Fil ... gin.tar.gz

and installed also the Mono environment under Debian-Linux with

apt-get install mono-complete

Then I start VRS for German language under VNC with user rights

mono VirtualRadar.exe -culture:de-DE

Thats all for VRS to run.


2. Setup portforwarding

I think thats quite simple. VRS runs under user rights on HTTP-Port 8080.
This cannot changed under this user rights.
You must set a portforwarding rule in your internet router to internal port 8080
with the IP adress from your computer wich runs VRS.

Internet -> Port xxxx (8080) -> Portforwarding -> 192.168.xx.xx:8080

I use an Apache webserver with ProxyPass/ProxyPassReverse wich runs all HTTP traffic througt
port 80 on my websserver. The configuration is a little bit tricky and I think you don't need this.
The simple portforwarding it's yours. ;-)

Regards,
Steffen

GaryG
Posts: 60
Joined: Wed Jan 30, 2013 1:26 am

Re: VRS V1.2.1

Post by GaryG » Mon Mar 11, 2013 12:00 am

Hi

I'm a new Linux / Raspberry Pi user.

Mono appears to have installed ok (logged in as root for this), lots of grep errors at the end but I assume that's for documentation (who needs that!) ;-)

Logged in as pi for the rest...

I made a directory /home/pi/vrs and all the files from your three archives appear to be in their proper places. The pi directory has the same files/paths as my Windoze version.

mono starts but it's crashing, gdb info starts with apparent attempt to access address 0x0

Where have I gone wrong? Where should I have unpacked the archives?

GaryG

aalested
Posts: 14
Joined: Fri Feb 22, 2013 10:48 am

Re: VRS V1.2.1

Post by aalested » Mon Mar 11, 2013 2:31 pm

jimjack wrote:Hi Erik,

yes I can help you. No problem.


1. Installation VRS:

I've decompressed the files for Linux in one directory

http://www.virtualradarserver.co.uk/Fil ... dar.tar.gz
http://www.virtualradarserver.co.uk/Fil ... ack.tar.gz
http://www.virtualradarserver.co.uk/Fil ... gin.tar.gz

and installed also the Mono environment under Debian-Linux with

apt-get install mono-complete

Then I start VRS for German language under VNC with user rights

mono VirtualRadar.exe -culture:de-DE

Thats all for VRS to run.


2. Setup portforwarding

I think thats quite simple. VRS runs under user rights on HTTP-Port 8080.
This cannot changed under this user rights.
You must set a portforwarding rule in your internet router to internal port 8080
with the IP adress from your computer wich runs VRS.

Internet -> Port xxxx (8080) -> Portforwarding -> 192.168.xx.xx:8080

I use an Apache webserver with ProxyPass/ProxyPassReverse wich runs all HTTP traffic througt
port 80 on my websserver. The configuration is a little bit tricky and I think you don't need this.
The simple portforwarding it's yours. ;-)

Regards,
Steffen
Hi Steffen.

Many thanks for your reply to my query.

I will walk through what your wrote, and see what I can do :-)

Erik

Chriso
Posts: 45
Joined: Sat Oct 13, 2012 9:46 pm
Contact:

Re: VRS V1.2.1

Post by Chriso » Sat Mar 16, 2013 1:48 am

Can't run VirtualRadar.exe
Image

Anyone know why?

Raspberry Pi

GaryG
Posts: 60
Joined: Wed Jan 30, 2013 1:26 am

Re: VRS V1.2.1

Post by GaryG » Sat Mar 16, 2013 4:46 am

looks like the same errors I see - still a Unix novice. If I figure out an answer, I'll post...

GaryG

Post Reply