No Picture or Thumbnails (3.0.0 Beta Preview 6 mono)

Discussions about the preview versions of Virtual Radar Server.
Forum rules
Please bear in mind if you do install a preview version that it is unfinished code, there may be bugs, bits missing, things that don't work etc.

Posts in this forum will not show up in forum search results. Old threads will be pruned occasionally.
Post Reply
matthys70
Posts: 31
Joined: Thu Mar 13, 2014 9:24 am

No Picture or Thumbnails (3.0.0 Beta Preview 6 mono)

Post by matthys70 »

Hello,

Working with the VRS 3.0.0 Beta Preview 6 under Mono runtime version 5.18.0, I noticed that for some reason the Picture or Thumbnails is not working.
I tried both Firefox and Chrome but no luck. Also no clue in the log about why .... though I do see this error:
[2021-05-24 09:53:45.367 UTC] [t5] Exception caught during data download: System.InvalidOperationException: Could not download http://www.virtualradarserver.co.uk/Fil ... verage.csv: Error: NameResolutionFailure ---> System.Net.WebException: Error: NameResolutionFailure

And I wonder if this NameResolutionFailure is the reason...

I tried to get the file manually with wget and works fine, including resolving etc:
wget http://www.virtualradarserver.co.uk/Fil ... verage.csv
--2021-05-24 11:57:08-- http://www.virtualradarserver.co.uk/Fil ... verage.csv
Resolving www.virtualradarserver.co.uk (www.virtualradarserver.co.uk)... 145.239.2.204
Connecting to www.virtualradarserver.co.uk (www.virtualradarserver.co.uk)|145.239.2.204|:80... connected.
HTTP request sent, awaiting response... 200 OK
Length: 340 [application/octet-stream]
Saving to: ‘FlightNumberCoverage.csv.1’

Anyone with the same issue for VRS 3.0.0 Beta Preview 6?
JayM
Posts: 5
Joined: Tue Jul 20, 2021 5:18 am

Re: No Picture or Thumbnails (3.0.0 Beta Preview 6 mono)

Post by JayM »

Uninstall mono 5.18.0 and install the latest version of mono-complete (6.12.0) as per the instructions on the mono-project.com's web page. I had the same issue with mono 5.18 and VRS 2.4.4. It's the mono version that causes it, though I've no idea why.
matthys70
Posts: 31
Joined: Thu Mar 13, 2014 9:24 am

Re: No Picture or Thumbnails (3.0.0 Beta Preview 6 mono)

Post by matthys70 »

Thanks! Gone try that...

Indeed I noticed that mono is reporting:
Mono JIT compiler version 5.18.0.240 (Debian 5.18.0.240+dfsg-3 Sat Apr 20 05:16:08 UTC 2019)
matthys70
Posts: 31
Joined: Thu Mar 13, 2014 9:24 am

Re: No Picture or Thumbnails (3.0.0 Beta Preview 6 mono)

Post by matthys70 »

Dammm .. now running mono 6 but VRS not running at all, I get:
mono VirtualRadar.exe
[ERROR] FATAL UNHANDLED EXCEPTION: System.TypeInitializationException: The type initializer for 'System.Windows.Forms.XplatUI' threw an exception. ---> System.ArgumentNullException: Could not open display (X-Server required. Check your DISPLAY environment variable)
Parameter name: Display
at System.Windows.Forms.XplatUIX11.SetDisplay (System.IntPtr display_handle) [0x003d0] in <6d635ac3dc1c4424ad385ded79f1e868>:0
at System.Windows.Forms.XplatUIX11..ctor () [0x00077] in <6d635ac3dc1c4424ad385ded79f1e868>:0
at System.Windows.Forms.XplatUIX11.GetInstance () [0x00019] in <6d635ac3dc1c4424ad385ded79f1e868>:0
at System.Windows.Forms.XplatUI..cctor () [0x000c0] in <6d635ac3dc1c4424ad385ded79f1e868>:0
--- End of inner exception stack trace ---
at System.Windows.Forms.Application.EnableVisualStyles () [0x00006] in <6d635ac3dc1c4424ad385ded79f1e868>:0
at VirtualRadar.Program.Main (System.String[] args) [0x00021] in <f36b216085b147fb8e79f331ea8d5244>:0

Okay ... to fast .... I just found this what did the trick (add "-nogui" parameter):
>Do you want to use VRS in headless mode?
>Then you need to add the "-nogui" parameter.
Post Reply